Missing option to join from browser in Zoom

I’ve found a small problem with Zoom. The “lobby” page the link directs you to usually contains links to either launch/join the meeting from the client or the browser. I prefer not to install the client and always want to join via the browser. The problem is that the “join via browser” option is not available on my desktop. On my laptop on the other hand this option is always available, but very inconvenient since all my work is on the desktop and the laptop’s sound is horrible. I run XFCE Manjaro on both of them.

Is there something that prevents the “join via browser” option from being available on the desktop?

I hope I posted this in the right section.

What version(s) of zoom do you have installed exactly?

I have not found out under what circumstances Zoom displays the “join from browser” link, but it always appeared. Sometimes right in the beginning, somtimes after waiting for some seconds, sometimes after several page reloads, but it always appeared in the end.
The behaviour is the same on 2 desktops (CentOS 7 and Manjaro) and happens in Firefox and Chrome. So really no indications on the details for displaying the link.

I don’t have it installed.

I see. I misunderstood your post then.

So you are talking about their website?

Thanks, I’ll try continuously refreshing the page with the next meeting.

Yes and no…? I get sent a link by my superior who hosts the meeting and I follow the link. The option “join via browser” does not appear when I follow the link on my desktop but does show up when I use my laptop.

So I tried your suggestion continuously refreshing the page for about 2 minutes and in the end I switched to my laptop or phone again. :roll_eyes:
The only other thing I just thought of trying is to use their main website to navigate to “join a meeting” and entering the meeting ID manually.

Manual navigating from their home site also does not work…

The option never appeared on their website when I was on Linux.
Would not be the first website to block Linux users to prevent “spammers and hackers” :roll_eyes:
I’m unable to try it myself at the moment (limited internet connection and my phone would need an update to be able to host), so could you please try if it works when you use the user agent Switcher to appear as to use windows?


Best Regards, Julius

The most recent update I can give is that I got it working. I searched through the site’s HTML on the my laptop (where the link does appear) to get the URL that allows joining from the browser. I typed that into my desktop’s browser and it worked!

Assuming the URLs follow the same format for each meeting with ID: XXXX; replace /j/XXXX#success with /wc/join/XXXX or /wc/XXXX/join in the address bar and it will connect to the meeting.
NOTE: I’ve only tried this once so there is no guarantee that it works. Expect edits after some more experimentation

1 Like

I’ll try the extension when the solution I came up with does not work anymore. Thanks for the suggestion.

I have to ask: do websites deny access based on hardware/os/software/etc.?

some do. It is similar to anticheat where they are trying to minimize attacks and misuse. Whether this practice is effective, however, is a different question. I’m unsure whether Skype still blocks linux users for example, but it apparently used to (I read about someone complaining that he has to use that extension to get it working).

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.