Missing kernel and cannot boot from USB

Another victim of the Manjaro 20 update. I delayed as long as possible, having read the litany of problems associated with this update, but today I updated my secondary Manjaro machine before rebooting my primary workhorse.

I had not downloaded the 20 update before. I set the update in motion using the gui updater (via Remmina, as usual). I kept an eye on it but towards the end I was distracted for a moment. When I looked back the machine was no longer visible in Remmina so I reloaded it. All the workspaces had been wiped as though by a reboot, but I think the delay was not sufficient for a true reboot. I checked for further uodates but there were none so I re-started the computer via the Log Out option. Mistake. The machine appeared to reboot but then began a noisy several minutes (high fan activity) and I could not regain access via Remmina.

Adding a monitor showed the machine was in the boot selection menu. Adding a keyboard, I selected the most likely option and got the message that it could not find linuz-4.19 - install a kernel! I tried the other options (four in all) and got the same response. I tried the editor, as advised in several of the posts hereabouts, and changed the kernel number through all the likely ones, taking my primary machine’s grub setup as example. I also tried modifying the disk number (it showed hd1 where my primary machine was hd0. No differrence. Each time it showed the previous error on reboot with alterations to the kernel number as appropriate.

Following other instructions, I tried to boot from the original USB installation stick (Manjaro 17) but it persistently came up as a failed grub for v20. I can think of no reason why it could not boot from the USB device (BIOS is set to read the USB first).

A couple of other pertinent observations:

I had the backup drive connected during update (1Tb USB drive). After the failure became obvious I removed it. Looking at it on another machine, it seems intact and working.

I updated the primary machine in the same way but have not yet rebooted it, nor did it reboot itself.

I suspect, from the secondary machine’s apparent auto reboot, that the update installation did not in fact complete.

If I could boot from the USB I could probably reinstall, or at least try to fix it, but the drive failure is a puzzle in itself. I have rearranged the priorities and returned 1st Boot Drive to Removable but no difference.

Was there a BIOS or CPU patch included in the 20 update? BIOS is Megatrends copyrighted 2011. The CPU info I have is: 6 x AMD FX 6200

I have spent several hours trying to get it to boot, plus reading a large number of posts plus the wiki (which gave no relevant solution).

Any suggestions, please?

Hello @dstiles :wink:

OMG, what have you done? That is the worst decision you could do. Manjaro is a partial rolling release and has no fixed versions. The versions are only indicators for the current state.

So the kernel has been removed due the update. Did you try installing a current kernel? Did you run sudo update-grub ? With the app mhwd-kernel you can install another kernel.

Use a current version for booting. Grub bootloader changed also.


  1. Boot with a current Manjaro Install ISO
  2. open a terminal and chroot: manjaro-chroot -a
  3. install/reinstall a kernel: mhwd -i linux54
  4. keep sure grub finds the kernel: update-grub
  5. exit and reboot

I meant, I had not updated. I did not “download” a release, merely clicked Update in the gui.

I have no way of installing a kernel. There is no OS. There is no USB boot.

I cannot boot from ANY type of OS from USB. I tried two versions of Mint, which I know work, as well as manjaro. The USB boot method is somehow broken.

All I have is the GNU GRUB 2.02 panel, which I have never used before.

If there is no kernel, you will not be able to boot.

That is bad. But maybe the “linuz-4.19” has been renamed and grub hadn’t updated it. Otherwise i see no solution without booting with a USB.

You could do this in emergency grub:

  1. type ls to list all partitions,
  2. type ls (hd0,1) for example if this partition is present.
  3. type ls (hd0,1)/boot to look if the kernel is there.

If not, then without booting a install disk there will be no solution i fear.

Good luck :slight_smile:

Thanks for your suggestions, megavolt. I had another play with ls and changing the disk ID and various names, but nothing worked. ls came up with hd0: and


but nothing worked. I assume the boot image has been trashed.

I tried an installation from DVD but that wouldn’t boot either. For some reason it always drops straigth into the hard disk.

Not sure what to do now. Possibly scrap the machine and go for a raspberry? Hey, ho!

Thanks again.

Your main problem is the inability to boot from usb/DVD. Since they both fail, most likely it isn’t an hardware problem but a bios setting so I’d suggest you look there.

Thanks, but the settings in Bios’ Boot are quite straightforward. Possibly there is something in another menu but I haven’t touched BIOS since setting the machine up originally. I’ll have one final look, though.

Have you tried booting from USB without a hard disk attached? … If you have a USB to SATA interface or a dock you might then be able to check the hard disk.

Thanks for the idea. Just tried booting with no disk. It asks for a boot medium. :frowning:

The grub usb command shows no usb devices. I know there used to be six of them…

Can anyone suggest a reason why a simple update could not only destroy the boot loader but also disable usb and dvd drives? Judging by the number of people complaining about boot problems with the new 20 version there must be something seriously wrong with the software as applied to certain types of hardware.

Does anyone know HOW usb can be disabled anyway?

What command, please???

An update don’t do this. It does not touch your UEFI. So I assume the problem persist, but you didn’t know it.

That can only disabled in the UEFI.

Is there no way to open a boot manager? Like typing F10 at boot time to choose a device?

How did you flash the ISO to the USB Drive?

In Grub command interface, at the grub prompt: usb

I didn’t think an update could kill usb (and dvd) either, nevertheless, I know usb was working before the update because the external backup was up to date and I sometimes run a dvd or cd in the dvd drive. And now it occurs to me: the USB keyboard works. Hmm. Looks more as if the boot loader cannot see the usb devices.

Not UEFI, by the way.

I’ve tried all the ways suggested here and elsewhere as to why this should happen, for manjaro and other OSs, even windows.

The ISO was created on a Mint computer three years ago. I used it to install to my primary machine and later to my secondary. I have also tried Mint ISOs, again known working. But with no actual usb drive being seen by the boot loader, obviously none of them could load.

Erm… well. Never done this with grub. I normally use the BIOS/UEFI Boot Manager. In the BIOS you should be able to change priority order of the drives.

I know. That’s the problem.

My primary machine required a reboot today; it locked up in (I think) an out-of-memory swap situation. Consider my trepidation when my only recourse was to hit the reset button. :frowning:

It all worked ok! :slight_smile:

Still nothing on the secondary machine, though.