Missing hardware detection problem with drivers?!

Hello, firstly I am really pretty new in Linux environment, spend last 2 days just trying to make my pc workable and I already manage to ■■■■ my disk/OS so I did not had other choice then reinstall whole OS again… for like fourth times now.

My current problem is that in my previous build I manage to install every (for me essential) software, everything worked fine and even manage to play couple hours of ESO, which a thought would be on Linux impossible, I tried to follow guide which should auto-mount my disks and manage to f* my system again (I even could not start terminal through alt + ctrl f1). So I install it whole again I manage to install steam, set on proton and mount my disks so I can setup Steam library… well ESO worked I mean it started load up but in character selection screen was whole pc suddenly slowed down I manage to start game itself and I had missing textures and some graphical glitches. I figure out the problem can be in drivers.

I found out that Manjaro has tool named Hardware detection but… suprise suprise my version is very special (Cinnamon 20.2 full version) and do not have Hardware detection (at least i cannot find it start + find + hardware/hardware detection/hwids) even it show in package manager that it is downloaded. I have NVIDIA GTX 1660 Ti if it help somehow.

I am just generally frustrated, spend my whole life troubleshooting problems with Windows but in two days I encounter so many problems so I am feeling like real idiot whose cannot even run one of more wholesome linux distro and cannot setup it without breaking it… one step forward and two back.

Any help is appreciated, thank you!

edit: this screen should somehow help understand my spec

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=405a7c9d-1e0a-4e51-81d4-de2f9f9cf39d rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Cinnamon 4.8.6 tk: GTK 3.24.27 vt: 7 dm: LightDM 1.30.0 
  Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: ASUS product: All Series v: N/A serial: <filter> 
  Mobo: ASUSTeK model: Z87-A v: Rev 1.xx serial: <filter> 
  UEFI: American Megatrends v: 1602 date: 10/29/2013 
  Info: Quad Core model: Intel Core i5-4570 bits: 64 type: MCP arch: Haswell 
  family: 6 model-id: 3C (60) stepping: 3 microcode: 28 cache: L2: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 26120 
  Speed: 1001 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 1001 2: 889 
  3: 1291 4: 2409 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics 
  vendor: ASUSTeK driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:0412 
  class-ID: 0380 
  Device-2: NVIDIA TU116 [GeForce GTX 1660 Ti] vendor: Gigabyte 
  driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:2182 class-ID: 0300 
  Display: x11 server: X. Org 1.20.10 driver: loaded: modesetting,nouveau 
  unloaded: intel alternate: fbdev,nv,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1016x286mm (40.0x11.3") 
  s-diag: 1055mm (41.6") 
  Monitor-1: DP-2 res: 1920x1080 hz: 60 dpi: 102 size: 476x268mm (18.7x10.6") 
  diag: 546mm (21.5") 
  Monitor-2: HDMI-4 res: 1920x1080 hz: 60 dpi: 92 size: 531x299mm (20.9x11.8") 
  diag: 609mm (24") 
  OpenGL: renderer: NV168 v: 4.3 Mesa 20.3.4 direct render: Yes 
  Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio 
  vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 00:03.0 
  chip-ID: 8086:0c0c class-ID: 0403 
  Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8c20 
  class-ID: 0403 
  Device-3: NVIDIA TU116 High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus-ID: 01:00.1 chip-ID: 10de:1aeb 
  class-ID: 0403 
  Device-4: Z-Star Micro Venus USB2.0 Camera type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 2-14:5 chip-ID: 0ac8:3420 
  class-ID: 0102 
  Device-5: C-Media CM108 Audio Controller type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus-ID: 2-3:2 chip-ID: 0d8c:013c 
  class-ID: 0300 
  Sound Server-1: ALSA v: k5.9.16-1-MANJARO running: yes 
  Sound Server-2: JACK v: 0.125.0 running: no 
  Sound Server-3: PulseAudio v: 14.2 running: yes 
  Sound Server-4: PipeWire v: 0.3.23 running: no 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8168 v: 8.048.03-NAPI modules: r8169 port: d000 
  bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 2.6 TiB used: 126.92 GiB (4.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SV300S37A120G 
  size: 111.79 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: SSD serial: <filter> rev: BBF0 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST32000641AS 
  size: 1.82 TiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC13 scheme: GPT 
  ID-3: /dev/sdc maj-min: 8:32 vendor: Seagate model: ST500DM002-1BD142 
  size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: KC48 scheme: MBR 
  ID-4: /dev/sdd maj-min: 8:48 vendor: Patriot model: Burst size: 223.57 GiB 
  block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s rotation: SSD 
  serial: <filter> rev: 61.3 scheme: GPT 
  ID-1: / raw-size: 223.27 GiB size: 218.77 GiB (97.98%) 
  used: 14.22 GiB (6.5%) fs: ext4 dev: /dev/sdd2 maj-min: 8:50 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/sdd1 maj-min: 8:49 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nouveau temp: 31.0 C 
  Fan Speeds (RPM): N/A gpu: nouveau fan: 899 
  Processes: 215 Uptime: 8m wakeups: 0 Memory: 19.43 GiB 
  used: 2.13 GiB (11.0%) Init: systemd v: 247 tool: systemctl Compilers: 
  gcc: 10.2.0 Packages: pacman: 1346 lib: 434 flatpak: 0 Shell: Bash v: 5.1.0 
  running-in: gnome-terminal inxi: 3.3.03

Welcome to the forum! :wave:

Please edit your post and add your full your system info with inxi -Fazy as outlined here:

See Manjaro Hardware Detection - Manjaro

Manjaro Settings Manager > Hardware Configuration

1 Like

Well positive is that I finally find hardware detection! Thank you!

Negative is that after I updated drivers and restarted computer the OS did not boot. It came right in to the black screen.

That’s the open-source driver, you’ll probably want the proprietary NVIDIA driver. The easiest way is using the Auto Install Proprietary Driver Button in Hardware Configuration.

Are you able to switch to a TTY (Ctrl + Alt + F1 - F7)? If not, you may need to boot from a live USB and use manjaro-chroot.

What’s the output of:

mhwd -l --pci

See Configure Graphics Cards - Manjaro

Yep click on that and after that i restart it.

Yep fortunately I was able to get in manjaro-chroot

Network controller Realtek semiconductor Co., Ltd.:
name version freedriver Type
network-r8618 2016.04.20 true PCI

Display controller nVidia Corporation
name version freedriver Type
video-linux 2018.05.04 true PCI
video-modesetting 2020.01.13 true PCI
video-vesa 2017.03.12 true PCI

Display controllerIntel Corporation:
name version freedriver Type
video-linux 2018.05.04 true PCI

video-nvidia is missing from that output.

What’s the output of the following (the same as clicking the Auto Install Proprietary Driver button):

sudo mhwd -a pci nonfree 0300

Skipping already installed config ‘video-linux’ for device 0000:01:00.0 (0300:10de:2182) Display controller nVidia Corporation TU116 (GeFroce GTX 1660 Ti)

What’s the output of the following? It will show the currently installed configs:

mhwd -li --pci

name version freedriver Type
video-linux 2018.05.04 true PCI
video-modesetting 2020.01.13 true PCI
video-vesa 2017.03.12 true PCI
video-linux 2018.05.04 true PCI

edit: it basicly said same thing but in one tab

That’s the full output? That does not compute as video-linux is the free driver. Also, please post terminal output between three backticks ` above and below the text:


It appears you’ll need the hybrid drivers since you have an Intel / NVIDIA combo:

sudo mhwd -i pci video-hybrid-intel-nvidia-460xx-bumblebee

See also:

Error: config ´video-hybrid-intel-nvidia-460xx-bumblebee´ does not exist!

also sorry for terrible formating

Oh, sorry. It should be:

sudo mhwd -i pci video-hybrid-intel-nvidia-prime


sudo mhwd -i pci video-hybrid-intel-nvidia-460xx-prime

hmm wierd, both commands throw error

does not exist!

Please reinstall the mhwd-db package and try sudo mhwd -a pci nonfree 0300 again.

Since you are on a Desktop PC and do not seem to have any monitor connected to the Intel GPU, why not disable it from BIOS and then have proper dGPU, the Nvidia one, work with the video-nvidia drivers ?


Hmm did not think about that, guess that would make things easier.