Missing Desktop Effects


I am missing some of my desktop effects like wobbly windows and such, Not sure how they went missing or how to retrieve them.

    qdbus org.kde.KWin /KWin supportInformation
KWin Support Information:
The following information should be used when requesting support on e.g. https://forum.kde.org.
It provides information about the currently running instance, which options are used,
what OpenGL driver and which effects are running.
Please post the information provided underneath this introductory text to a paste bin service
like https://paste.kde.org instead of pasting into support threads.


KWin version: 5.20.5
Qt Version: 5.15.2
Qt compile version: 5.15.2
XCB compile version: 1.14

Operation Mode: X11 only

Build Options
HAVE_X11_XCB: yes

Vendor: The X.Org Foundation
Vendor Release: 12010000
Protocol Version/Revision: 11/0
SHAPE: yes; Version: 0x11
RANDR: yes; Version: 0x14
DAMAGE: yes; Version: 0x11
Composite: yes; Version: 0x4
RENDER: yes; Version: 0xb
XFIXES: yes; Version: 0x50
SYNC: yes; Version: 0x31
GLX: yes; Version: 0x0

Plugin: org.kde.kwin.aurorae
Theme: __aurorae__svg__Nordic
Plugin recommends border size: No
Blur: 1
onAllDesktopsAvailable: true
alphaChannelSupported: true
closeOnDoubleClickOnMenu: false
decorationButtonsLeft: 0, 2
decorationButtonsRight: 6, 3, 4, 5
borderSize: 3
gridUnit: 10
font: Noto Sans,10,-1,0,50,0,0,0,0,0,Regular
smallSpacing: 2
largeSpacing: 10

Name: KWin::X11StandalonePlatform

focusPolicy: 0
xwaylandMaxCrashCount: 3
nextFocusPrefersMouse: false
clickRaise: true
autoRaise: false
autoRaiseInterval: 0
delayFocusInterval: 0
shadeHover: false
shadeHoverInterval: 250
separateScreenFocus: false
placement: 4
focusPolicyIsReasonable: true
borderSnapZone: 10
windowSnapZone: 10
centerSnapZone: 0
snapOnlyWhenOverlapping: false
rollOverDesktops: true
focusStealingPreventionLevel: 1
operationTitlebarDblClick: 5000
operationMaxButtonLeftClick: 5000
operationMaxButtonMiddleClick: 5015
operationMaxButtonRightClick: 5014
commandActiveTitlebar1: 0
commandActiveTitlebar2: 28
commandActiveTitlebar3: 2
commandInactiveTitlebar1: 4
commandInactiveTitlebar2: 28
commandInactiveTitlebar3: 2
commandWindow1: 7
commandWindow2: 8
commandWindow3: 8
commandWindowWheel: 28
commandAll1: 10
commandAll2: 3
commandAll3: 14
keyCmdAllModKey: 16777250
showGeometryTip: false
condensedTitle: false
electricBorderMaximize: true
electricBorderTiling: true
electricBorderCornerRatio: 0.25
borderlessMaximizedWindows: false
killPingTimeout: 5000
hideUtilityWindowsForInactive: true
compositingMode: 1
useCompositing: true
hiddenPreviews: 1
glSmoothScale: 2
xrenderSmoothScale: false
maxFpsInterval: 16666666
refreshRate: 0
vBlankTime: 6000000
glStrictBinding: true
glStrictBindingFollowsDriver: true
glCoreProfile: false
glPreferBufferSwap: 101
glPlatformInterface: 1
windowsBlockCompositing: true

Screen Edges
desktopSwitching: false
desktopSwitchingMovingClients: false
cursorPushBackDistance: 1x1
timeThreshold: 150
reActivateThreshold: 350
actionTopLeft: 0
actionTop: 0
actionTopRight: 0
actionRight: 0
actionBottomRight: 0
actionBottom: 0
actionBottomLeft: 0
actionLeft: 0

Multi-Head: no
Active screen follows mouse:  no
Number of Screens: 1

Screen 0:
Name: DP-2
Geometry: 0,0,2560x1440
Scale: 1
Refresh Rate: 74.923

Compositing is active
Compositing Type: OpenGL
OpenGL vendor string: Mesa/X.org
OpenGL renderer string: llvmpipe (LLVM 11.0.1, 256 bits)
OpenGL version string: 3.1 Mesa 20.3.3
OpenGL platform interface: GLX
OpenGL shading language version string: 1.40
Driver: LLVMpipe
GPU class: Unknown
OpenGL version: 3.1
GLSL version: 1.40
Mesa version: 20.3.3
X server version: 1.20.10
Linux kernel version: 5.10.7
Direct rendering: Requires strict binding: yes
GLSL shaders:  yes
Texture NPOT support:  yes
Virtual Machine:  no
OpenGL 2 Shaders are used
Painting blocks for vertical retrace:  no

Loaded Effects:

Currently Active Effects:

Effect Settings:
zoomFactor: 1.2
mousePointer: 0
mouseTracking: 0
focusTrackingEnabled: false
textCaretTrackingEnabled: false
focusDelay: 350
moveFactor: 20
targetZoom: 1


dimStrength: 25
dimPanels: false
dimDesktop: false
dimKeepAbove: false
dimByGroup: true
dimFullScreen: true

zoomDuration: 300
border: 10
desktopNameAlignment: 0
layoutMode: 0
customLayoutRows: 2
usePresentWindows: true


layoutMode: 1
showCaptions: true
showIcons: true
doNotCloseWindows: false
ignoreMinimized: false
accuracy: 20
fillGaps: true
fadeDuration: 150
showPanel: false
leftButtonWindow: 1
rightButtonWindow: 2
middleButtonWindow: 0
leftButtonDesktop: 2
middleButtonDesktop: 0
rightButtonDesktop: 0




type: 1



  Kernel: 5.10.7-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 
  root=UUID=c41d4dba-1ead-4f8c-a8cd-90a6a9c7150a ro quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.20.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 
  dm: SDDM Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: PRIME B450-PLUS v: Rev X.0x 
  serial: <filter> UEFI [Legacy]: American Megatrends v: 2202 date: 07/14/2020 
  Info: 8-Core model: AMD Ryzen 7 3700X bits: 64 type: MT MCP arch: Zen 2 
  family: 17 (23) model-id: 71 (113) stepping: N/A microcode: 8701021 
  L2 cache: 4 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 129657 
  Speed: 4050 MHz min/max: 2200/4050 MHz boost: enabled Core speeds (MHz): 
  1: 4050 2: 4050 3: 4050 4: 4050 5: 4050 6: 4050 7: 4050 8: 4050 9: 4050 
  10: 4050 11: 4050 12: 4050 13: 4050 14: 4050 15: 4050 16: 4050 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: ASUSTeK driver: nvidia 
  v: 390.141 alternate: nouveau,nvidia_drm bus ID: 09:00.0 chip ID: 10de:1c03 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: 
  loaded: nvidia display ID: :0 screens: 1 
  Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.7x13.5") 
  s-diag: 692mm (27.3") 
  Monitor-1: DP-2 res: 2560x1440 dpi: 109 size: 597x336mm (23.5x13.2") 
  diag: 685mm (27") 
  OpenGL: renderer: llvmpipe (LLVM 11.0.1 256 bits) v: 4.5 Mesa 20.3.3 
  compat-v: 3.1 direct render: Yes 
  Device-1: NVIDIA GP106 High Definition Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 09:00.1 chip ID: 10de:10f1 
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 0b:00.4 chip ID: 1022:1487 
  Device-3: Kingston HyperX 7.1 Audio type: USB 
  driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-2:2 chip ID: 0951:16a4 
  serial: <filter> 
  Sound Server: ALSA v: k5.10.7-3-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: f000 bus ID: 04:00.0 
  chip ID: 10ec:8168 
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 2.96 TiB used: 1.47 TiB (49.8%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 960 EVO 250GB 
  size: 232.89 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: 2B7QCXE7 temp: 35.9 C 
  ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1SB102 
  size: 931.51 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: CC43 
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital 
  model: WD2003FZEX-00SRLA0 size: 1.82 TiB block size: physical: 4096 B 
  logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1A01 
  ID-1: / raw size: 232.88 GiB size: 228.23 GiB (98.00%) 
  used: 61.84 GiB (27.1%) fs: ext4 dev: /dev/nvme0n1p1 maj-min: 259:1 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 57.9 C mobo: N/A gpu: nvidia temp: 47 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0% 
  Processes: 364 Uptime: 5h 04m wakeups: 0 Memory: 7.77 GiB 
  used: 5.82 GiB (74.9%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.1 Packages: pacman: 1404 lib: 428 flatpak: 0 Shell: Zsh v: 5.8 
  running in: konsole inxi: 3.2.02
  1. In the future, when providing code/output, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text so that the output looks like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua.
    Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat.
    Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur.
    Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    instead of like this:

    Lorem ipsum dolor sit amet, consectetur adipiscing elit, sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla pariatur. Excepteur sint occaecat cupidatat non proident, sunt in culpa qui officia deserunt mollit anim id est laborum.

    (as that makes both our lives much easier)

  2. No need to do anything right now as I’m an editor here on this site and have fixed it for you already. However, in the future I might not see your post so review my edits by pushing the orange pencil above the post I just fixed. :wink:

  3. Can you go to System Settings→Compositor and re-enable compositor on startup and then reboot?



Ensure you’re not using XRender backend. Some effects, including wobbly windows, do require OpenGL.


No I checked that already and I am using OpenGL 3.1

Thank you for that, I am not sure what I was thinking at the time. I was trying to put the three ``` but I messed up on doing that. I re-enabled compositor and rebooted. That didn’t fix anything.

Can you verify that a theme update didn’t turn the wobbly windows off?


How can I do that?

  • Go to System Settings
  • Type effec
  • Click on Desktop Effects
  • Type wo
  • Verify “Wobbly Windows” is still on as per below screenshot:

If not, turn it back on.

Yeah it wasn’t there. I had to reinstall Manjaro to get it back

You should have said that before re-installing as you can download individual plug-ins for the KDE compositor… :stuck_out_tongue_winking_eye: :crazy_face:

But anyway, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Sorry about that, I have a foggy memory and tend to forget tings easily.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.