Missing Desktop apps and icons?

Using KDE Plasma 5.23.4 / KWin / Theme:Breath Light [Plasma] / Breeze [GTK2/3] …am assuming this is a simple enough problem not to bother with inxi…

This may sound strange but there is no visual display of my “desktop” items (folders and/or app icons) that are actually contained in my /Desktop folder. In other words, what I am seeing visually on the GUI “desktop” display is apparently not reflecting the contents of my /Desktop folder.

I confirm that these items (ls -l) exist in the CLI and they’re shown through Dolphin in the “~/Desktop” folder. But my GUI “desktop” doesn’t show any of them. (I did manage to manually get the Trashcan to appear via a widget.)

The funny thing is that they had been there - but after tweaking my Plasma settings I must have turned visibility off (or changed what my GUI “desktop” is showing - apparently it’s not the ~/Desktop folder and I cannot find a way to make them visible again. :man_shrugging:

Right-click the desktop and choose “Enter Edit Mode”. Then right-click it again and choose “Configure Desktop and Wallpaper”. Change the Layout to “Folder View” and select your ~/Desktop folder. Click OK.

Don’t forget to right-click the desktop again and select “Exit Edit Mode” afterwards.

Many thanks for your prompt reply!

Unfortunately, I’ve actually tried this repeatedly before posting … to no avail.

When I do select “Folder View” I see no option anywhere enabling me to select only the ~/Desktop … instead I get everything in my /Home folder appearing on my GUI desktop (/Desktop, /Documents, /Downloads, …) for a very cluttered GUI desktop that is not actually reflecting what’s in /Desktop.

Is there an option somewhere I’m missing that allows me to select which folder is the one that shows up on the GUI desktop (i.e., /Desktop instead of /home)?

Put differently, when I do select “Desktop” as my “Layout” (and apply) there are no icons of any sort (neither apps nor folders) seen on my GUI “desktop” - it’s blank even though those items are still existing in my actual /Desktop folder.

Sometimes a picture tells the story better. Here are the actual contents of my /Desktop folder:

When I select “Desktop” as my Layout, I get nothing showing up. OTOH, when I select “Folder View” I get this GUI desktop result:

There should be. :thinking:

1 Like

Well, at least I know I’m not nuts (well, perhaps this conundrum doesn’t disprove that :wink: )

I’d offer a screenshot of the drop-down menu when I select “Layout” but invoking the screenshot app collapses the drop-down choices. The only two drop-downs offered are “Desktop” and “Folder View” - and “Folder View” shows all of the folders in my /home directory whereas “Desktop” shows nothing on the GUI desktop.

Oh well, it’s an oddity but not worth losing sleep over. For losing sleep, I’m exploring whether or not to use fstrim on my dual-boot Manjaro/High Sierra MacBookPro with an internal OWC Mercury 500g SSD. :roll_eyes:

It is possible to set a delay on the screenshot. If you set, say, a 4-second delay, and you click on Take a new screenshot, then you’ve got the time to open the drop-down. :stuck_out_tongue:

The KDE developers have apparently moved things around for Plasma 5.23. You have to select “Folder View” and click Apply, and then you must click on Location in the left-hand pane. There you can select what folder to show.

fstrim is normally executed automatically every Sunday at midnight in Manjaro, or on the next boot if the system was not running at that time.

This is taken care of by /usr/lib/systemd/system/fstrim.timer, which is normally enabled by default and which in due time then invokes /usr/lib/systemd/system/fstrim.service, which itself then runs /usr/bin/fstrim on all read/write-mounted filesystems. :wink:

If you are using Spectacle for screenshots, then yes it is possible. Change the delay to 5 seconds (or whatever you’re comfortable with), Make sure to uncheck On Click, then click Take a New Screenshot and quickly go to the window and get the drop down menu showing and wait a few moments for the screenhot to be taken. He’s an example


Eureka! You’ve pointed me in the right direction to resolve this. Somehow or other the location had been set to /home - instead of desktop. You have to come back to the location folder choices (on the left) AFTER having already selected “Folder” layout and then exiting and returning again. Prior to that the location choices aren’t offered.

Many thanks!

@Aragorn Yes indeed … having researched TRIM issues extensively (including the excellent Arch wiki on the topic) I’ve got fstrim timer service enabled/started on both my MacBookPro (vintage 2011) and Dell Optiplex 7010 (2013) both of which I’ve upgraded with different brands of 500g SSD internal drives.

My concern is whether this is necessary and/or wise given that (a) the MacBookPro is setup as a dual boot and MacOS supposedly takes care of some of this garbage collection, and (b) the OWC brand touts not needing to enable further trim services because supposedly it has firmware that does this already. The other brand makes no such claims. :nerd_face:

Perhaps I’ll post this as a separate topic, but don’t want to drag folks into the weeds of my particular configuration/brands of devices, etc.

It depends on whether the macOS filesystem is mounted in Manjaro or not. fstrim.service only works on read/write-mounted filesystems, not on unmounted fileystems or filesystems that are mounted read-only.

That is possible, yes ─ I’m not familiar with the brand, but I know some devices do it via their firmware.

Well, the fstrim runs only once per week, so I don’t think it would cause any harm. But if the firmware does it itself, then you don’t need it, I guess. :man_shrugging:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.