Missing Configure GNOME/GTK Application Style Button in System Settings

Operating System: Manjaro Linux
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.89.0
Qt Version: 5.15.2
Kernel Version: 5.15.12-1-MANJARO (64-bit)
Graphics Platform: X11

Hello all, I’m missing the Gnome/GTK Application Style button after re-installing Manjaro, which was a somewhat of a none traditional installation. I’m having a few programs, one being Pamac, that is not following the global them which lead me to certain applications settings will be configured with that button.
(Image is from a friend with a similar build to me to use as an example)

Your are looking for kde-gtk-config package.

That’s one of the steps that I had taken, it was installed and I re-installed it and even went as far as re-booting the system.

So, you click on that button and what happens ?

screenshot taken from your screenshot

It will apply the plasma theme to any GTK apps. But I have no button to click!

So, you can click on that one and will open this settings

hence you select the desired GTK theme and will apply on the fly …

Are you referring to the actual Apply button ? … that was removed long time ago.
If you are referring to something else, please be specific, share the exact thing you see there.

I guess you could give this a whirl:
https://wiki.archlinux.org/title/KDE#Configuration_related

If you would actually read my post, you will see that I am being very specific as I had stated in my original question that I’m missing the button

Try to launch systemsettings from terminal and open Application Style KCM. Will there be something notable in the output?

So, after some more digging, by my friend that has better Google Fu then me, found this post on Reddit.

“Anyone still facing this problem, it is possible that you have disabled xsettingsd (GNOME/GTK Settings Synchronization Service) in startup and shutdown > Background Services on kde System Settings.”

That setting was disabled and once it was enabled the Configure Gnome/GTK Application Style button returned. Thanks everyone for your help, much appreciated.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.