MINSIGSTKSZ Error after update manjaro

After I update my system with

sudo pacman -Syu

I can’t run my college coursework and get this error

> make                                                                                
g++ -c -Wall -Wpedantic -Werror -Wextra -std=c++14  main_test.cpp
In file included from /usr/include/signal.h:328,
                 from catch.hpp:8034,
                 from main_test.cpp:2:
catch.hpp:10822:58: error: call to non-‘constexpr’ function ‘long int sysconf(int)’
10822 |     static constexpr std::size_t sigStackSize = 32768 >= MINSIGSTKSZ ? 32768 : MINSIGSTKSZ;
      |                                                          ^~~~~~~~~~~
In file included from /usr/include/bits/sigstksz.h:24,
                 from /usr/include/signal.h:328,
                 from catch.hpp:8034,
                 from main_test.cpp:2:
/usr/include/unistd.h:640:17: note: ‘long int sysconf(int)’ declared here
  640 | extern long int sysconf (int __name) __THROW;
      |                 ^~~~~~~
In file included from main_test.cpp:2:
catch.hpp:10881:45: error: size of array ‘altStackMem’ is not an integral constant-expression
10881 |     char FatalConditionHandler::altStackMem[sigStackSize] = {};
      |                                             ^~~~~~~~~~~~
make: *** [makefile:33: main_test.o] Error 1

before I update the system, it’s run well without an error
How I can fix this? I really need to fix this for my coursework

Your homework is to develop and compile a file
and this has worked before and now it doesn’t?
… when it has worked before, you already have the resulting compiled object - why do it twice?

Either use the same compiler that you used previously (but that is unlikely to be the problem here)
fix your code.

Forum Rules - Manjaro
As a matter of principle, do not ask for homework answers, nor post answers to such requests. Homework assignments are designed to encourage a student to learn by their own personal research. Topics deemed to be about homework will be closed.

There was a change in glibc. You need to adjust your code. Similar issue here. error: call to non-'constexpr' function 'long int sysconf(int)' · Issue #106 · OpenImageDenoise/oidn · GitHub

Beside that… seems you did not update your system for a long time? … :no_mouth:

1 Like