MinisForum UM700 freezes a few seconds after restart

I’ve had the Mini running for two months already with only one (possibly self inflicted) glitch. After a week using their branded Manjaro version I’ve installed vanilla Manjaro KDE. After rebooting from the last update it gives me enough time to login in a Plasma session or into a console. Either way after 10 sec, enough to see the output of inxi, it freezes, the keyboard or mouse don’t respond and the only way to get out is to turn the machine off.
Is not an hardware problem because I can start a session with the Live version of Manjaro KDE. I tried comparing the /etc dirs and files with the live version but didn’t find anything very evident as problematic.
How should I continue investigating the problem?

Since I believe it some sort of powersaving issue of cpu or gpu, try different kernels.

Try adding processor.max_cstate=0 to the kernel parameter. That force the cpu to stay on C0.

I tried the three kernels installed, 5.10, 15 and 17 but w/o luck.

I will try your advice though,

Perhaps @spikerguy knows of a trick :slight_smile:


After giving some thought to it - I think it could be the tlp configuration.

tlp.service is disabled on live ISO but enabled after install.

To test disable the service

sudo systemctl disable --now tlp
1 Like

Yes. It was tlp! As I said a self inflicted wound.
Thank you very much :+1: :+1:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.