Minecraft Solutions for Older GPUs? (GLFW error 65543: GLX: Failed to create context: GLXBadFBConfig)


I’ve been using some Google-Fu skills and have tried both the official launcher and the PolyMC launcher from the AUR to no avail. It seems that the “old solution” for pre-OpenGL 4.3 graphics devices was to launch with a forced MESA GL version of 4.3. This does not work anymore, with the minecraft launcher and PolyMC launcher both coming up with a blank screen (cannot link but DuckDuckGoing PlanetMinecraft glfw error 65543 should bring you to the post with solutions)

So with MESA_GL_VERSION_OVERRIDE=4.3 minecraft-launcher out of the question, what are other options?

So far I have:

  1. Suggested falling back to 1.12.5 which seems to work A-OK with the older chipsets.
  2. Suggested a) installing the newest mesa-git (22.2.0-devel) from AUR then b) launching with MESA_LOADER_DRIVER_OVERRIDE=zink. This is less than ideal on Core 2 Duo systems such a T7300 as it is then using an llvmpipe vulkan implentation. However, combined with Optifine (which has OpenGL 3.3 support) it seems that Minecraft will indeed launch.

That being said, it is of course suboptimal.

The problem here is the friend I am helping (and trying to duplicate on my own older machines) is in Poland with a couple of Ukrainian kiddos. “Just buy a new laptop” is not an acceptable answer: therefore I am trying to do with Linux users do best… find workarounds.

Using an older version (1.12.5) with the OpenGL drivers or running the latest (1.18.2 as of today) with the Zink OpenGL-On-Vulkan-On-LLVMpipe is not… highly performant but it gets the job done.

What are the chances of OpenGL 3.3 support for Optifine or even OpenGL 4.3 support for the crocus driver on 965GM, Intel HD and Intel HD 2000 chipsets?

Hello @Eirikr1848 :wink:

Just a simple fact:

OpenGL is an API which calls the GPU. Every version have a set of features. The GPU proclaim to support a set of features by calling the OpenGL Version Number.

If you have a GPU which supports features of OpenGL 2.1 and you overwrite/fake it with OpenGL 4.3, which is needed to run the game, then the GPU does not respond magically to the OpenGL API Calls, which it does not have. It is like running DirectX12 API on a GPU which supports DIrectx9 API Calls. What happens with the extended API Calls in the newer version, when the GPU cannot respond to that? Obviously this will not work, maybe crash or freeze. Sometimes it can help, if the graphic features in the game can be disabled, but that is commonly a bad idea.

So by explaining that it is obvious: OpenGL or MESA is not the bottleneck. It is the GPU and what the game is needed to run.

So, as it turns out: “spoofing” the version seems to have worked fine – get about 25-30FPS this way, more with sodium.

So hey, something funny is up. llvm and spirv or something stepping in to fill in the gaps with cpu rendering if the gpu can’t handle the shader calls or something? (Don’t know; just guessing)

i think minecraft 2D version will be suitable for old GPU

In fact, you run OpenGL fully with your CPU, but don’t expect good performance. :wink: