Minecraft. Can only press a control key once, before i can't again

My problem is the following:

I load a world or join a server (doesn’t matter really)
I can move my mouse freely
But whenever I try to press W,A,S,D (shift and spacebar work fine), it is being registered as held, not pressed, and even if I unpress it, it still is registered as held. So basically I can “hold” each button once, but when I somehow stop moving I cannot press that again. I only found that if I open in game chat and then close it i can once more “hold” a button.

I tried installing a mckeyboardfix mod that fixes some old minecraft library bug. The minecraft version is 1.8.9. I tried using different launchers, tried using a vanilla launcher, the issue is still present. Looked around on the web, didn’t find anything useful. I am on a laptop, if that is important.

I fixed it for myself.

I looked at this Arch forum post → Minecraft controls issue / Multimedia and Games / Arch Linux Forums
and the member Inchw0rm suggested deleting directories .local and .config .
However they didn’t specify where from to delete them and at first I deleted .local and .config from the home directory, which ultimately led to me losing some of my system configuration which is fine, because I can redo all that. Then I looked at my official Minecraft launcher’s directory and noticed there were also directories with those names so I yeeted them in a trash bin like a responsible human. I then deleted some more files and restarted (honestly I didn’t know restarting actually changed anything, because of some video years prior, in which some dude stated that there is no need to restart the system at all if you are running Linux). After all that, the movement worked just fine, so I guess there is my solution.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.