Minecraft 1.8.9 doesn't capture cursor

Here are my specs:


Operating System: Manjaro Linux

KDE Plasma Version: 5.27.7

KDE Frameworks Version: 5.108.0

Qt Version: 5.15.10

Kernel Version: 6.4.9-1-MANJARO (64-bit)

Graphics Platform: Wayland

Processors: 4 × Intel® Core™ i5-6500 CPU @ 3.20GHz

Memory: 23.3 GiB of RAM

Graphics Processor: AMD Radeon RX 6400

Manufacturer: Dell Inc.

Product Name: OptiPlex 7050

So I have two monitors. Whenever I play Minecraft on 1.8.9, the game does not capture the cursor. If I turn to the left, the cursor will go onto my second monitor. If I turn to the right, the cursor, although not visible, will hit the border of my main monitor and my view will stop turning.

I am using Prism Launcher. I’ve tried another solution out there where gamescope -f -H $HEIGHT -h $HEIGHT -- is used (in my case, since my monitor is 1920x1080, the command (i think) would be gamescope -f -H 1920 -h 1080 --). I’ve tried pitting that in the “Wrapper Command” and “Pre-launch Command” sections in the Custom Commands tab of the instance settings in Prism. I get two different errors, depending on which field I put it in.

If I put it in Pre-Launch, I get The process failed to start. Pre-Launch command failed with code 0. (Which is strange, because if I run the same command in a terminal, it initializes.)

If I put it in Wrapper Command, I get The wrapper command "gamescope" couldn't be found. (Maybe Prism only supports a few wrappers.)

“Wrapper command” is the correct place to put it. The command is wrong. You’re telling gamescope to upscale the game from h = 1080 to H = 1920. Try just gamescope -f --.

Hmm, it still gives me the “The wrapper command “gamescope” couldn’t be found.” error.

Hmm, I don’t know why that is. Is gamescope on your PATH? What does which gamescope say?

Probably not, and it says /usr/bin/gamescope. I installed gamescope-git from the AUR, if that helps any.

/usr/bin/gamescope is correct and gamescope -f -- works for me in “Wrapper command”.

Are you using the Flatpak version of Prism Launcher? Perhaps it needs extra permissions (I don’t use Flatpak so no idea).

Yeah I am using flatpak. I’ll try installing using the AUR and see if it works.

Ok, yeah it works, but it looks weird (vaguely blurry, i guess??)

Ok, now you know it’s working use gamescope -f -w 1920 -h 1080 --

-f on it’s own runs the game at 1280x720 and upscales it, that’s why it’s blurry.

Ok, it worked. Thank you for your help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.