Minecraft (1.20.6) ignores optirun and starts with iGPU

  1. Optirun works fine. I tested it with several applications like blender, glxgears, openspades, rigs of rods
  2. I tried Modrinth and PolyMC as Minecraft launchers, both having the problem described in the title.
  3. I tried sudo optirun, optirun, primusrun, sudo primusrun
  4. This problem didnt occur on my last manjaro installation for some reason (it was 1.20.4 back then if that matters).

The following code snippet seams interesting: It says my GPU (Nvidia Quadro K1000, more details in profile) isn’t supported, but why tf not, i mean it worked a while ago on an old installation.

[16:05:49] [Render thread/INFO]: OpenGL Vendor: Intel
[16:05:49] [Render thread/INFO]: OpenGL Renderer: Mesa Intel(R) HD Graphics 4000 (IVB GT2)
[16:05:49] [Render thread/INFO]: OpenGL Version: 4.2 (Core Profile) Mesa 24.0.6-manjaro1.1
[16:05:49] [Render thread/INFO]: Initializing ImmediatelyFast 1.2.15+1.20.6 on Mesa Intel(R) HD Graphics 4000 (IVB GT2) (Intel) with OpenGL 4.2 (Core Profile) Mesa 24.0.6-manjaro1.1
[16:05:49] [Render thread/WARN]: Force disabling fast buffer upload optimization due to unsupported GPU
[16:05:49] [Render thread/INFO]: Found Iris/Oculus 1.7.0+mc1.20.5. Enabling compatibility.

Is it maybe due to my mods? I use Fabulously Optimized (BETA) for 1.20.6