Middle Click not working

Since I tried the package “gestures” and deinstalled it again the middle click on my touchpad does no longer work as expected. (doesn’t paste). I can paste by 3-finger-click., but that’s not what I want.
With an external mouse it is working normally.
I don’t think its a hardware issue, because the touchpad is working normally in a live system.
Thanks for any help!
Helmut

Have a look at this section:

https://wiki.archlinux.org/title/Libinput#Via_Xorg_configuration_file

Guess “clickfinger” is enabled on your side which is the default.

thank you for the answer and the link.
I tried to find something like “clickfinger” in the config-files, but there was nothing.
Is it posible, that I used synaptics before the change and now libinput ist active? But the conf-file for synaptics has a bigger number.
I’m really confused by all these options, buttonmappings …

The next step is to reinstall the hole system. Next time I dont find the switch for the light in my room I will build a new house. :roll_eyes:

I have a couple of thoughts that might point you in the right direction. Unfortunately I cannot test them. I did wget the package and extracted it to see what it installed and if there were any directions. In no particular order:

  • Review Settings > Mouse and Touchpad

  • Make sure gestures did not leave any configuration files in your home directory. There may also be a file /etc/libinput-gestures.conf.

    # search for gestures config files
    find ~ -iname *gestures*
    
  • gestures instructions. There are no processes or services running and I’m assuming you rebooted.

    # any running processes 
    # search for gesture,  not found return 1 to eliminate error; separate processes w/ ,
    ps -p "$(pgrep -d',' gesture || echo 1)" -F
    
  • This part can be done from the command line with gsettings or use the dconf-editor. I’m not sure if this is the correct key. You’ll have to report back. How XFCE uses its’ own options and dconf isn’t always clear. I usually just dump them all using gsettings and xfconf-query and start looking from there. Unfortunately dconf is binary, but xfce config files are located ~/.config/xfce4/xfconf/xfce-perchannel-xml/. I will grep them, but as far as editing, I use the Settings GUI or gsettings.

    The gestures package has its’ own schema “com.gitlab.cunidev.Gestures”. I do not know how to get rid of unused schemas.

    # review key value pairs
    gsettings list-recursively  org.gnome.desktop.peripherals.touchpad
    
    # get value for key
    gsettings get org.gnome.desktop.peripherals.touchpad middle-click-emulation 
    
    # set value for key
    gsettings set org.gnome.desktop.peripherals.touchpad middle-click-emulation true