Middle-click functionalities lost after system upgrade and reboot (as of 2024-02-22 16:00 UTC)


I have just upgraded the complete Manjaro system and rebooted my laptop and now I notice middle click no longer pastes selected text, nor does it open a new tab in firefox. I don’t know if both cases are linked though.

I have tested my hardware (a Dell Latitude E6530 Synaptics touchpad) and he middle click paste works in a console/TTY (not a GUI terminal emulator, in text mode).

I can also add that Xfce Clipboard Manager “catches” text selections and shows them in the drop-down menu. Paste with middle click still doesn’t work even after closing/quitting and restarting clipman. I also tried checking and unchecking the “Synchronize mouse actions” checkbox in clipman’s preferences, then close and restart it doesn’t change anything.

EDIT: The issue seems tied to my Xfce profile. I have tested a… test profile using another local user account and middle click functionalities seem unaltered.

Is it a known issue and there a fix?

So the question now is: how can I restore that functionality without destroying my whole Xfce profile and re-creating it again?

Thanks in advance.

Check if you had some variable or script in ~/.profile, and if so, copy it to .bash-profile
That is what changed in this update.

Nope, I don’t have a dot-profile directory.

look better :slight_smile: show the hidden files. And it is a file in your home.

I know how to manage a Linux system since 2004. When I say I don’t have anything named .profile in my home directory, there is none… Really. None.

EDIT: And I use the command line, not those fancy GUI’s.

Then it is something else. Maybe something connected to the touchpad driver, or libinput, or gesture control…a lot got updated this time. I do not know (mine still works)

No, it’s not hardware, it’s software and it is related to my profile, hence my “updated” question in my initial message.

Would erasing my .cache/session or .cache/xfce4 directory help restore that functionality? (BTW this is also why I asked, as it would basically force me to reconfigure/pimp my desktop all over again. So I’d prefer a more selective approach, if you see what I mean.)

It could. Just try. You can clear out the whole ~/.cache folder without consequence.

It makes more sense to me to delete:
but you’ll have to do it while the session is not running (logged out) as the session manager will get in your way otherwise.
From TTY for instance.

I have no issue - this is just a guess.

Thanks @Nachlese will try that and report when I’m done :+1:


That didn’t work. I’ll try going deeper in .cache

Also turns out there’s a lot more that’s now broken after that update… That’s the one thing I hate the most with the GTK world. Been using Gnome in early 2004 and everytime there was an update I was off to completely wipe out my desktop profile and recreate/reconfigure it from scratch. And trying to find what to clean was only going to be a huge waste of time… just like I feel how it’s going to be right now :frowning: .

That made me switch to KDE and, oh boy, what a breeze! Nothing broke even after dozens of updates and upgrades. Just had to revert to GTK environments after KDE3 stopped being maintained. That’s when I started with Xfce.

Just to be sure:
when messing with anything in
you have to be logged out of this users Xfce session - the session cannot be active,
or you need to stop the session manager before making any changes.

You could compare the respective files in ~/.config/xfce4 between the test user that you created and the one where things don’t seem to work now.
It’s not even 20 files - likely even less in your test users account.
Easy with “mc” (two pane console/terminal file manager) …

You can also back up/move this folder before you possibly delete it to start from scratch.
And then add back the things that you customized.

re KDE/Plasma vs GTK and Gnome:
I can’t stand KDE/Plasma - and from reading here in the forum, it’s also not always a walk in the park.
Gnome is good as long as you use it as it is - as soon as you wish to adapt things, it gets “ugly” …
That is maybe less noticable on fixed release distributions - on rolling distros like Arch/Manjaro it has long ago become a no go for me.
Things are way too complicated to configure and break frequently during updates.
Therefore: Xfce it is :wink:

Good luck!


Looks like we’re on the same page on that one, good ol’ Norton Midnight Commander :wink:

Anyway. Now I’ve just come to something I cannot explain. Here is:

  • I opened a second session with a test user, then ran sudo -i
  • from there I terminated my regular, not-test session with loginctl terminate-user <my account>
  • then deleted ~/.config/xfce4/xfconf/xfce-perchannel-xml/pointers.xml (from the other session)
  • logged back
    Problem NOT solved.

Then I rebooted and did this:

  • open a session on the console with my login, ran sudo -i
  • copied all files (there are like 20 of them) from ~/.config/xfce4/xfconf/xfce-perchannel-xml/ to my test user’s Xfce directory, same path
  • logged in with Xfce
    The problem was there!

I then terminated my test user session, remove ~/.config/xfce4/xfconf/xfce-perchannel-xml/pointers.xml and the problem was… GONE!

Then I terminated my test session again, copied that damn’ file over again to confirm it was it and the problem happened again.

WTF is going on here???

I’m at a loss :frowning:

I’ll try the procedure again, now that I know what configuration file messes up with my mouse… just in case.

Well, scrap that all… The issue was due to disabling the Joystick in the middle of the keyboard — I regularly hit it when I type and I had disabled it today. Turns out that is what also disables the middle click :facepalm:

And I feel like an i-d-i-o-t¹ now. Well, at least my remaining troubles now don’t require a complete profile wipe.

So far.

Time to get some sleep.

¹ Wut? Had to spell that word otherwise it’s… censored?

That is the problem with “bad language” filters (assuming it is due to this).
In order to prevent people from calling each other names, you now cannot even more or less correctly describe yourself. :wink:

Yeah, turns out I found a workaround to let the truth shine anyway :wink:

In support centers of yesteryear the approach would be to have the user create an “ID.10.T” file as well as entreat them to call up this file during any future help requests with other techs. :innocent:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.