microSD, 'read-only' mode

I have a microSD card that when it reaches a certain amount of storage it becomes ‘read only’. My informatic skills are not too great (like my english, I write from google translate), but I think when writing over a bad sector this problem appears.
I have tried repeatedly to format, change the file system, use tools like gnome disk utility or Gparted, and got no solution.
I have read that Badblocks might work in this case (assuming this issue is about bad sectors), I ran it once but aborted knowing it would take 7 days! First I want to be sure that it will be useful.

Some data:
micro SD 1TB FAT32
OS: Manjaro 20.2 Nibia Gnome 3.38.2
Kernel: x86_64 Linux 5.8.18-1-MANJARO

PD: Just 2 months ago I am using Manjaro (and Linux)… :blush:

Seeing the size of the microSD card; 1TB
Did you install M$ on it?

Because if you’re using M$ to boot from that card with NTFS filesystem on it, and try to access it from Linux, it is a known issue of M$.
In this case shutdown your M$ completely, do not use “reboot system” because the filesystem M$ uses will be left in a state that will not allow Linux to write to it.
If i recall correctly, you should also disable “Fast reboot” in the M$ settings.

Thanks for your reply. I forgot to clarify, the microSD card I only use as external storage, I have Manjaro installed on an SSD. I have tried installing Manjaro on the card, but it always failed.

Could you provide the output of sudo fdisk -x wrt the microSSD?

Disk /dev/mmcblk0p1: 999.02 GiB, 1072692199424 bytes, 2095101952 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disc Label Type: dos
Disk ID: 0x00000000

If the above info you gave is all you get from that command, then it is no wonder because it means you have no partition(s) setup on that device.
Which in turn means you are not able to “write” anything to it…
Try again after you create a partition on it and mount it.