Microphone volume mismatch between alsa and pulseaudio

Initially in the sound menu in the tray the microphone volume was 100% and everything was fine. At some point the microphone just started humming and I realized that it was Internal Mic Boost in Alsamixer. Now if you remove the microphone boost in alsamixer, in the system and in pavucontrol its volume is shown as 32%. And if in alsa the microphone volume is 0%, in the system and Pulseaudio it is 5%. How to remove the microphone boost and make it 100% volume in the system.

What you need to understand here ─ I know it’s complicated ─ is that PulseAudio runs on top of Alsa. In other words, the PulseAudio volume settings apply to the sound that it receives from Alsa. By consequence, if you remove the boost in Alsa, then it’ll also be gone from the output you get from PulseAudio.

You should think of it as two sets of controls that are in series. First in line is the Alsa subsystem, which sits at the lowest-level ─ it’s embedded in the kernel, even ─ but then the output from Alsa goes through a second set of controls, namely PulseAudio, which can handle input from yet other sources than Alsa and can act as a kind of amplifier, with over-boost.

So the settings of those two subsystems will never be the same, because they serve different purposes. PulseAudio is an audio multiplexer and offers fine-tuning over the different sound sources, including equalization effects (if you have the equalizer installed). Alsa is a lot more rudimentary. :wink:

Thanks for the detailed explanation, I understand. Then I want to ask, is it normal that the microphone is set to 32% in the system settings? It’s uncomfortable and strange to me. Now I raise the volume above 32% microphone boost and there is a lot of noise, can i turn off the possibility of boost that would be 100% microphone without boost and noise?

Well, this I don’t know, because I don’t have a microphone. :wink:

However, whatever you set it to, your settings should normally be preserved across reboots.

I suspect so, but given my lack of experience with that, I’m going to have to defer to someone more knowledgeable about these things than myself. :slight_smile:


1 Like