Microphone not working unless I open monitor, but then I can hear it


Newly setup PC with Manjaro KDE and something is wrong with my mic.
They cannot hear me, unless I add mic to monitoring devices on my sound card, but then I can hear it through my headphones.

Same PC, same card, same mic, same Kernel and was working before the format.
I re-downloaded latest ISO, re-formated for 2nd time, and the problem persists.

I moved my sound card (external SoundBlaster X5) to another Manjaro PC, and works fine.
I am really frustrated here and it is very annoying, cause except from my own voice in the headphones, I can hear every sound in the house…

I tried both “Analog Stereo Duplex” and “Digital Stereo Duplex”, same.

From my card, when I mute the Mic under monitoring section, it completely mutes mic.
Tried reset, repair firmware, but nothing worked, however, it works fine on another setup with same Kernel.

inxi -F

  Host: am5-manjaro-kde Kernel: 6.6.0-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.9 Distro: Manjaro Linux
  Type: Desktop System: Gigabyte product: X670E AORUS MASTER v: -CF
    serial: <superuser required>
  Mobo: Gigabyte model: X670E AORUS MASTER serial: <superuser required>
    UEFI: American Megatrends LLC. v: F13d date: 09/14/2023
  Info: 16-core model: AMD Ryzen 9 7950X3D bits: 64 type: MT MCP cache:
    L2: 16 MiB
  Speed (MHz): avg: 2072 min/max: 400/5759 cores: 1: 4121 2: 400 3: 400
    4: 400 5: 4748 6: 3301 7: 400 8: 400 9: 400 10: 3686 11: 4329 12: 4592
    13: 400 14: 3168 15: 400 16: 4673 17: 4403 18: 400 19: 4149 20: 400
    21: 400 22: 400 23: 400 24: 400 25: 3584 26: 400 27: 4044 28: 3817
    29: 3189 30: 400 31: 400 32: 3718
  Device-1: NVIDIA AD103 [GeForce RTX 4080] driver: N/A
  Device-2: AMD Raphael driver: amdgpu v: kernel
  Device-3: Logitech HD Pro Webcam C920 driver: snd-usb-audio,uvcvideo
    type: USB
  Display: x11 server: X.Org v: 21.1.9 driver: X: loaded: amdgpu
    unloaded: modesetting,radeon dri: radeonsi gpu: amdgpu resolution:
    1: 1080x1920~60Hz 2: 2560x1440~60Hz
  API: EGL v: 1.5 drivers: radeonsi,swrast platforms: x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.1.9-manjaro1.1
    renderer: AMD Radeon Graphics (raphael_mendocino LLVM 16.0.6 DRM 3.54
  API: Vulkan v: 1.3.269 drivers: radv surfaces: xcb,xlib
  Device-1: NVIDIA driver: snd_hda_intel
  Device-2: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Device-3: Creative [] driver: cdc_acm,hid-generic,snd-usb-audio,usbhid
    type: USB
  Device-4: Logitech HD Pro Webcam C920 driver: snd-usb-audio,uvcvideo
    type: USB
  API: ALSA v: k6.6.0-1-MANJARO status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
  Device-1: Intel Ethernet I225-V driver: igc
  IF: enp13s0 state: up speed: 1000 Mbps duplex: full mac: 74:56:3c:4b:74:7e
  Device-2: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi
  IF: wlp14s0 state: down mac: 5e:44:de:83:a6:72
  Device-1: Intel AX210 Bluetooth driver: btusb type: USB
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 5.52 TiB used: 1.12 TiB (20.2%)
  ID-1: /dev/nvme0n1 vendor: Kingston model: SKC3000D2048G size: 1.86 TiB
  ID-2: /dev/nvme1n1 vendor: Seagate model: XPG GAMMIX S50 Lite
    size: 953.87 GiB
  ID-3: /dev/nvme2n1 vendor: Samsung model: SSD 970 EVO 500GB
    size: 465.76 GiB
  ID-4: /dev/sda vendor: Crucial model: CT2000BX500SSD1 size: 1.82 TiB
  ID-5: /dev/sdb vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB
  ID-1: / size: 448.43 GiB used: 13.14 GiB (2.9%) fs: ext4 dev: /dev/nvme2n1p2
  ID-2: /boot/efi size: 299.4 MiB used: 296 KiB (0.1%) fs: vfat
    dev: /dev/nvme2n1p1
  ID-1: swap-1 type: partition size: 8.8 GiB used: 87.8 MiB (1.0%)
    dev: /dev/nvme2n1p3
  System Temperatures: cpu: 37.0 C mobo: N/A gpu: amdgpu temp: 33.0 C
  Fan Speeds (rpm): N/A
  Processes: 562 Uptime: 1h 35m Memory: total: 64 GiB available: 61.95 GiB
  used: 10.54 GiB (17.0%) Shell: Zsh inxi: 3.3.31

I have a webcam with mic, and if I enable it, it works fine. The problem is only with X5’s mic.
Any help how to troubleshot please?

Check ALSA mixer capture settings

alsamixer --card=X5 --view=capture

(if card name is not recognised use card number instead: --card=2)

Check PCM Capture Source is set to use ‘Microphone’ and not ‘What U Hear’

Use spacebar on keyboard to turn off CAPTURE for other audio inputs: ‘What U Hear’, ‘Aux In’, ‘SPDIF In’ and ‘Bluetooth’

When capture inputs are configured correctly, press F3 to show playback controls
It should be possible to mute the playback control for ‘Microphone’ monitoring by using M key without affecting capture input. Or else, reduce the playback level for ‘Microphone’ monitoring without affecting capture input level

Once ALSA capture and playback levels are set to your liking, use this command to save changes

sudo alsactl store

Thank you for your prompt answer.

This is how it is now:

This way, microphone works, but I can hear it too.
When I try to mute mic, nothing changes.
Changing PCM Capture to “What U Hear” (or anything else), makes mic to not work at all.

Into Playback, when I have PCM Capture to “What U Hear” and Microphone muted, I can still hear it, but it doesn’t work (I mean my friend in Discord, or Zoom, or Messenger, cannot hear me)
When PCM Capture is to Microphone, even with Mic muted, I can and they can hear me.

Still confused… :roll_eyes:

Ok… So, I moved the X5 to my other Manjaro PC in order to verify it is working, and copy the ALSA mixer settings, but it turns out it has the same behaviour.

Then I tried it to my son’s gaming PC (Windows 10) and works fine.
I also tried it with USB power, but not connected to any source, and also works fine.
That assures me there is no hardware issue with the X5, but Manjaro/Linux related
Maybe some recent patch/update broke this functionality?

Didn’t Manjaro change from pulseaudo to pipewire a while ago. If you reinstalled manjaro, pipewire should be the main interface right?

If you are not using pipewire, I would recomend you try that. Stuff “just works” in pipewire where in pulseaudio you need to configure files everywhere to get some things working.
No need for sinks or alsamixer settings.

pamac install manjaro-pipewire takes care of everything without you having to remove any pulseaudio related things.

I downloaded latest ISO (manjaro-kde-23.0.4-231015-linux65.iso) and re-install. It came with PusleAudio not pipewire

I wish it was that easy… I had always trouble setting up pipewire in the past and mostly with my Windows VM where either I don’t have sound, or I have huge latency (~1 sec). Probably I am doing something wrong, but at least PulseAudio works. This is the first time I had an issue.

It is that easy. I did it a few months ago, took about 30 seconds.
Please post errors you get when trying to.

Not getting any errors. I have peculiar behavior with my sound and problems with my VMs, not errors, but as I said, no sound at all, or high latency.
Will create a Timeshift snap on weekend and give it a try.

Is the latency high with pipewire?
Install it and come back if that is actually true on manjaro. What is going on in vm:s I can not speak of. But to me it seems a manjaro-vm should work the same.

If you want to keep trying to find a solution using pulseaudio, I assume you have looked at this?

I suggest you reduce Microphone monitor audio level to 0 and turn off the Auto-Gain control so it does not affect Microphone capture level

It may help reduce confusion if you turn down capture and monitoring levels to 0 for the Aux, SPDIF, Bluetooth and What U Hear inputs if they are not used
Also suggest using F3 to show playback controls only and F4 to show capture controls only

Latest Manjaro ISOs use PulseAudio as default software audio server
Replacing PulseAudio with PipeWire will not help to resolve issues in ALSA

Creative Labs’ What U Hear™ allows user to mix all inputs and outputs in ALSA without need of a software sound server or mixer. This hardware mixing function is similar to OBS (or Voicemeeter on Windows) but without a full mixer GUI

Some of my community radio colleagues are still using Soundblaster Live and Audigy cards for the ‘What U Hear’ mixing with minimal additional software.
I use an Audigy PCI card on an older system because the surround channels can be used as multiple stereo outputs in JACK
But If OP just wants to talk to people on Discord, Zoom, or Messenger, the additional complexity of using What U Hear mixing is probably best avoided for now

1 Like

I stand corrected then. I was under the impression that it would do exactly that.
From arch wiki:

PipeWire is a new low-level multimedia framework. It aims to offer capture and playback for both audio and video with minimal latency and support for PulseAudio, JACK, ALSA and GStreamer-based applications.

If the error is INSIDE ALSA, neither pulse nor pipe would solve that I guess.

But if you say you KNOW it doesn’t work, I am not going to argue since you are using this stuff, I have not.

After many changes and test, somehow I got it working…
Below is my ALSA mixer settings in case someone has the same issue (although I think it was like this before but wasn’t working)

Thank you all for your help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.