Microphone not working only in firefox

Hi! I’m having an issue on Firefox since some time. I am not able to receive input from my microphone, even though it asks me permission for it. However, I am able to use my microphone in every other app I have tested, including chromium, obs-studio and cheese. What could this be?

I like firefox better than other browser, it would be nice to not have to reinstall my whole system to use it.

I forgot to provide the output of inxi -Fza

~ >>> inxi -Fza                                                                
System:
  Kernel: 5.7.14-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.7-x86_64 
  root=UUID=ad907671-db3c-4d5f-87dc-99bf69229b6d rw quiet 
  udev.log_priority=3 
  Desktop: GNOME 3.36.4 tk: GTK 3.24.22 wm: gnome-shell dm: GDM 3.36.3 
  Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP Laptop 14-cf0xxx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: HP model: 84B3 v: KBC Version 74.30 serial: <filter> UEFI: Insyde 
  v: F.42 date: 06/20/2019 
Battery:
  ID-1: BAT0 charge: 36.9 Wh condition: 38.5/38.5 Wh (100%) volts: 13.2/11.6 
  model: HP Primary type: Li-ion serial: <filter> status: Charging 
CPU:
  Topology: Dual Core model: Intel Core i3-7020U bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 8E (142) stepping: A (10) 
  microcode: D6 L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 18406 
  Speed: 821 MHz min/max: 400/2300 MHz Core speeds (MHz): 1: 864 2: 900 
  3: 857 4: 900 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: Intel HD Graphics 620 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:5916 
  Device-2: Cheng Uei Precision Industry (Foxlink) HP TrueVision HD Camera 
  type: USB driver: uvcvideo bus ID: 1-6:2 chip ID: 05c8:03ba 
  serial: <filter> 
  Display: x11 server: X.org 1.20.8 compositor: gnome-shell 
  driver: amdgpu,ati,intel unloaded: modesetting alternate: fbdev,vesa 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: Mesa Intel HD Graphics 620 (KBL GT2) v: 4.6 Mesa 20.1.5 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus ID: 00:1f.3 
  chip ID: 8086:9d71 
  Sound Server: ALSA v: k5.7.14-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 4000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Realtek RTL8723DE 802.11b/g/n PCIe Adapter 
  vendor: Hewlett-Packard driver: rtl8723de v: v5.1.1.8_21285.20171026 
  port: 3000 bus ID: 03:00.0 chip ID: 10ec:d723 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 59.00 GiB (6.3%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: RSM7 scheme: GPT 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 port: 6060 bus ID: 00:17.0 chip ID: 8086.282a rev: 21 
Partition:
  ID-1: / raw size: 100.00 GiB size: 97.93 GiB (97.93%) 
  used: 29.05 GiB (29.7%) fs: ext4 dev: /dev/sda3 
  ID-2: /home raw size: 631.01 GiB size: 620.11 GiB (98.27%) 
  used: 29.94 GiB (4.8%) fs: ext4 dev: /dev/sda4 
Swap:
  Alert: No Swap data was found. 
Sensors:
  System Temperatures: cpu: 36.0 C mobo: 34.0 C gpu: amdgpu temp: 31 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 258 Uptime: 1d 2h 22m Memory: 3.73 GiB used: 2.12 GiB (56.8%) 
  Init: systemd v: 245 Compilers: gcc: 10.1.0 Packages: 1359 pacman: 1355 
  lib: 419 flatpak: 0 snap: 4 Shell: Zsh v: 5.8 running in: gnome-terminal 
  inxi: 3.1.05 

I do not have any idea on how to continue my search, I have reinstalled firefox many times, I have checked the system logs and have not encountered anything useful like missing packages or errors. Firefox just prompts me to use my microphone and then has no access to it, throwing no errors. The errors happened just after a system update, so I think it can be dependency-related but I can’t be sure.

I finally solved it. I did 2 things, and don’t know which fixed it:

  • I updated my system with today’s update
  • I removed the ~/.config/pulse folder, then rebooted my computer (this is more likely to have solved it)

I’ll leave this answer here for if anyone encounters the same problem.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.