Microphone Not working on Manjaro Linux Pahvo


Sorry for the really noob question.

I have setup Manjaro Linux 21.1.1 on my Ryzen 5 laptop. I have currently tried to tinker around with pulseaudio to figure out the issue, but I still am not able to get my microphone to work. My speakers are working normally but I can’t figure out the issue with my microphone. Any pointers to fix the issue would be really helpful

Does your microphone work with alsamixer ?

No, I don’t think it is able to detect it

You don’t give much information, and whatever you tried.
In case you didn’t try that yet, try below:

$ sudo arecord -l

Hello @panv

Here is the info I got—

**** List of CAPTURE Hardware Devices ****
card 1: Generic_1 [HD-Audio Generic], device 0: ALC236 Analog [ALC236 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Ok. you alsa is able to detect a microphone on card 1.
Let’s see about pulseaudio…


pacmd list-sources | grep -e index -e name: -e muted -e device.description

I get this message–

No PulseAudio daemon running, or not running as session daemon.

Generic driver will not work. You will likely need to find the right chipset driver made by realtek…etc if there is one, in AUR repo, and install it manually.

For more info, here is my output for sudo dmesg | grep snd

[   13.166137] snd_pci_acp3x 0000:02:00.5: enabling device (0000 -> 0002)
[   13.166403] snd_pci_acp3x 0000:02:00.5: ACP audio mode : 1
[   14.070903] snd_hda_intel 0000:02:00.1: enabling device (0000 -> 0002)
[   14.071075] snd_hda_intel 0000:02:00.1: Handle vga_switcheroo audio client
[   14.071342] snd_hda_intel 0000:02:00.6: enabling device (0000 -> 0002)
[   14.234508] snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC236: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:speaker
[   14.234520] snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   14.234525] snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x21/0x0/0x0/0x0/0x0)
[   14.234531] snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
[   14.234534] snd_hda_codec_realtek hdaudioC1D0:    inputs:
[   14.234536] snd_hda_codec_realtek hdaudioC1D0:      Mic=0x19
[   14.234540] snd_hda_codec_realtek hdaudioC1D0:      Internal Mic=0x12
[   16.384860] snd_hda_intel 0000:02:00.1: bound 0000:02:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])

Here is the result from inxi -Faxzy. I am copying the Audio section here, but can provide the full output if needed:

  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo
  driver: snd_hda_intel v: kernel bus-ID: 02:00.1 chip-ID: 1002:15de
  class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo
  driver: snd_pci_acp3x v: kernel alternate: snd_rn_pci_acp3x bus-ID: 02:00.5
  chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
  v: kernel bus-ID: 02:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes

I’d boot into Windows and check under device manager/ sound and see what the chipset is or check your manufacture’s website and then find the correct Linux driver

In Windows, the drivers are registered under Realtek. So do I need to install the proprietary drivers of Realtek into Manjaro?

actually, this will likely help:

Tried this solution. Unless I did something wrong, it didn’t work

Data in post #5 shows system has a Realtek ALC236 audio codec
Device is recognised in post #10 system data as Device-3: AMD Family 17h HD Audio
and is using the correct Linux audio driver snd_hda_intel

Kernel v5.13 is no longer supported in Manjaro repositories

I suggest you install kernel v5.15 using Manjaro Settings Manager GUI
( manjaro-settings-manager -m msm_kernel )

OR use these terminal commands to install new kernel and remove old one

sudo mhwd-kernel --install linux515
sudo mhwd-kernel --remove linux513

When you have rebooted to system to load the new kernel, please post more information about ALSA settings for audio device

amixer --card=1

and PulseAudio configuration

pacmd dump && pacmd list-cards