Microphone audio not received properly by applications

My microphone output doesn’t go through properly in some situations in Zoom , discord and other apps.

My computer detects the microphone and the microphone sound/noise .
The application DOES detect the microphone and the sound that the microphone registers (when going in that application at settings).

But when I talk nobody can hear me and on that application it doesn’t show like im speaking (for example on Zoom the person’s image that is talking comes out front and gets like a green border). Mine doesn’t do anything and people say that they can’t hear me. I even tried to give 150% volume from the manjaro settings.

On discord this happens only when someone shares their screen with me and i focus on it.
And again if I talk nobody can hear me.
But if someone shares their screen and I don’t focus it, I can still talk.

Discord is not a priority , I don’t really care if it works or not , I gaved that example as it might help to discover the problem.
I really need Zoom to work , since i use zoom for work.

Also made sure that I’m unmuted.

Some system info using inxi --admin --verbosity=7 --filter --no-host --width

Kernel: 5.15.55-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
root=UUID=7cd5db68-6feb-4517-849d-790babb1108d rw quiet apparmor=1
security=apparmor udev.log_priority=3
Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
Distro: Manjaro Linux base: Arch Linux
Type: Desktop Mobo: Gigabyte model: Z97MX-Gaming 5 v: x.x
serial: UEFI: American Megatrends v: F6
date: 09/18/2015
Message: No system battery data found. Is one present?
RAM: total: 15.49 GiB used: 2.48 GiB (16.0%)
RAM Report:
permissions: Unable to run dmidecode. Root privileges required.
Info: model: Intel Core i7-4790K bits: 64 type: MT MCP arch: Haswell
gen: core 4 built: 2013-15 process: Intel 22nm family: 6 model-id: 0x3C (60)
stepping: 3 microcode: 0x28
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 4370 high: 4402 min/max: 800/4400 scaling:
driver: intel_cpufreq governor: schedutil cores: 1: 4362 2: 4385 3: 4273
4: 4395 5: 4402 6: 4383 7: 4359 8: 4402 bogomips: 64031
Flags: abm acpi aes aperfmperf apic arat arch_perfmon avx avx2 bmi1 bmi2
bts clflush cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
dtherm dts ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
fsgsbase fxsr ht ibpb ibrs ida invpcid invpcid_single lahf_lm lm mca mce
md_clear mmx monitor movbe msr mtrr nonstop_tsc nopl nx pae pat pbe pcid
pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand
rdtscp rep_good sdbg sep smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
vpid x2apic xsave xsaveopt xtopology xtpr
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf
mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: mmio_stale_data status: Not affected
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl and seccomp
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics
vendor: Gigabyte driver: i915 v: kernel arch: Gen5.75 process: Intel 45nm
built: 2010 ports: active: none empty: HDMI-A-1,HDMI-A-2,VGA-1
bus-ID: 00:02.0 chip-ID: 8086:0412 class-ID: 0300
Device-2: NVIDIA GM204 [GeForce GTX 970] vendor: Gigabyte driver: nvidia
v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Maxwell process: TSMC 28nm
built: 2014-19 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:13c2 class-ID: 0300
Device-3: Creative Live! Cam Sync [VF0520] type: USB driver: uvcvideo
bus-ID: 3-13:3 chip-ID: 041e:406c class-ID: 0e02 serial:
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
alternate: fbdev,nouveau,nv,vesa gpu: i915,nvidia display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 101 s-size: 483x272mm (19.02x10.71")
s-diag: 554mm (21.82")
Monitor-1: DVI-I-0 res: 1920x1080 hz: 60 dpi: 102
size: 477x268mm (18.78x10.55") diag: 547mm (21.54") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 970/PCIe/SSE2 v: 4.6.0 NVIDIA 515.57
direct render: Yes
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
driver: snd_hda_intel v: kernel bus-ID: 00:03.0 chip-ID: 8086:0c0c
class-ID: 0403
Device-2: Intel 9 Series Family HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:8ca0
class-ID: 0403
Device-3: NVIDIA GM204 High Definition Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403
Sound Server-1: ALSA v: k5.15.55-1-MANJARO running: yes
Sound Server-2: sndio v: N/A running: no
Sound Server-3: JACK v: 1.9.21 running: no
Sound Server-4: PulseAudio v: 16.1 running: yes
Sound Server-5: PipeWire v: 0.3.56 running: yes
Device-1: Qualcomm Atheros Killer E220x Gigabit Ethernet vendor: Gigabyte
driver: alx v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
bus-ID: 03:00.0 chip-ID: 1969:e091 class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac:
IP v4: type: dynamic noprefixroute scope: global
IP v6: type: noprefixroute scope: global
IP v6: type: noprefixroute scope: link
Message: No bluetooth data found.
Message: No logical block device data found.
Message: No RAID data found.
Local Storage: total: 2.73 TiB used: 1.05 TiB (38.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial:
rev: 2B2QEXM7 temp: 43.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000DM003-1ER162
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
type: HDD rpm: 7200 serial: rev: CC43 scheme: GPT
Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVDRAM GH24NSB0 rev: LM01
dev-links: cdrom
Features: speed: 12 multisession: yes audio: yes dvd: yes
rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
ID-1: / raw-size: 1.82 TiB size: 1.79 TiB (98.37%) used: 621.23 GiB (33.9%)
fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
uuid: 7cd5db68-6feb-4517-849d-790babb1108d
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
label: NO_LABEL uuid: 05BD-8023
ID-3: /run/media/icefinity/bf32eda9-2890-43cf-bfc2-4b66de5a2710
raw-size: 931.22 GiB size: 915.53 GiB (98.32%) used: 457.05 GiB (49.9%)
fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
uuid: bf32eda9-2890-43cf-bfc2-4b66de5a2710
Alert: No swap data was found.
ID-1: /dev/sda1 maj-min: 8:1 size: 300 MiB fs: vfat label: NO_LABEL
uuid: 55A8-D0CA
Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
chip-ID: 1d6b:0002 class-ID: 0900
Hub-2: 1-1:2 info: Intel ports: 6 rev: 2.0 speed: 480 Mb/s
chip-ID: 8087:8009 class-ID: 0900
Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
Hub-4: 2-1:2 info: Intel Integrated Hub ports: 8 rev: 2.0 speed: 480 Mb/s
chip-ID: 8087:8001 class-ID: 0900
Hub-5: 3-0:1 info: Hi-speed hub with single TT ports: 14 rev: 2.0
speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
Device-1: 3-5:2 info: SiGma Micro XM102K Optical Wheel Mouse type: Mouse
driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
power: 100mA chip-ID: 1c4f:0034 class-ID: 0301
Device-2: 3-13:3 info: Creative Live! Cam Sync [VF0520] type: Video
driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 100mA
chip-ID: 041e:406c class-ID: 0e02 serial:
Hub-6: 4-0:1 info: Super-speed hub ports: 6 rev: 3.0 speed: 5 Gb/s
chip-ID: 1d6b:0003 class-ID: 0900
System Temperatures: cpu: 41.0 C mobo: N/A gpu: nvidia temp: 39 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 49%
Processes: 250 Uptime: 38m wakeups: 0 Init: systemd v: 251
default: graphical tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6
Packages: 1635 pacman: 1629 lib: 409 flatpak: 6 Shell: Zsh v: 5.9
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.19

Make sure lib32-libpulse is installed. If it is and zoom still uses ALSA devices by default select the “default” rather than a specifically named device. For example on ~/.config/zoomus.conf change it to be:


if is different …

Checked and still nothing.

Here is another clue … you should either install manjaro-pipewire to use only pipewire server, or manjaro-pulse to stick to pulseaudio … Might not have anything to do with your issue tho.
Did you reboot the system after making those changes, or at least restart the session?

Check alsamixer and disable auto mute …

Disabling auto mute in alsamixer worked.
At least for now.
Hope it will work forever.
Thank you.

1 Like

Installing manjaro-pulse metapackage would not deal with both sound servers running

PipeWire server can be stopped and disabled with this command

systemctl --user disable now pipewire.socket pipewire.service

ALSA settings should not change, But if they do, use this command to save settings

sudo alsactl store

ALSA settings will be restored to the same state whenever system is booted
User can also restore settings if needed:

sudo alsactl restore
1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.