MHWDCONFIG' is invalid!


I got through the big update last night relatively unharmed. I have a computer again, only took a couple of hours. That’s another story, but in case it is relevant, the only command that would allow me to reinstall the nvidia packages was the following that I got from another user in the stable update post:

sudo pacman -Rdd nvidia-455xx-utils

After that I reinstalled the nvidia drivers with the command found at the manjaro graphics card wiki:

sudo mhwd -a pci nonfree 0300

My system seems fine now, and I have nvidia stuff working again. However, I have had two minor “manjaro-system” package updates come through today. Both times, I got an error message like what is in the title. Here is the contents of the latest one. (I hope I am doing the quote stuff right, not real sure):

Synchronizing package databases…
Resolving dependencies…
Checking inter-conflicts…
Resolving dependencies…
Checking inter-conflicts…
Download of manjaro-system (20201231-7) started
Download of manjaro-system (20201231-7) finished
Checking keyring…
Checking integrity…
Loading packages files…
Checking file conflicts…
Checking available disk space…
Upgrading manjaro-system (20201231-5 -> 20201231-7)…
==> Checking if Nvidia drivers need an update …
==> Maintaining video driver nvidia-455xx
Warning: config ‘/var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG’ is invalid!
Error: config ‘video-nvidia-455xx’ is not installed!
Error while configuring manjaro-system
==> Installing Nvidia drivers for you …
Warning: config ‘/var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG’ is invalid!
Warning: a version of config ‘video-nvidia’ is already installed!
Use -f/–force to force installation…
Transaction successfully finished.

(This was done with the gui, so that is why the beginning is not present). Anyway, do I have something to worry about here? I was also getting this error message last night when I was unable to get the nvidia packages deleted / reinstalled so that I could have the system back up and running (was using a TTY).

I realize that there have been a lot of problems surrounding this topic. I did try and search this, but they all seem to be a little different, so perhaps I missed it. I am sure it is exhausting, so I appreciate any help given!

EDIT: About an hour after deleting ‘/var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG’, there was another small manjaro-system update. There were no more error messages, but it did update the nvidia drivers in the process. I am sorry, I wasn’t thinking and did not save the printout. But, restart and all is well. Thanks again, everyone!

1 Like

I have the same problem.

I have removed /var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG


I had the same problem.

After much reading, I came across a post by @philm, to which I can’t find a link to now, stating that it’s safe to remove the file. So I did:

sudo rm -f /var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG

And everything’s fine now. I don’t get the error when running mhwd -li anymore:

$ sudo mhwd -li
> Installed PCI configs:
NAME               VERSION          FREEDRIVER           TYPE
video-nvidia            2020.11.30               false            PCI

Warning: No installed USB configs!

Phil pushed an update yesterday to the testing branch that should fix the nvidia drivers issue. Hopefully it will make it to stable soon if it hasn’t already

As already stated it should be safe to remove the file, but check first if file /var/lib/mhwd/local/pci/video-nvidia/MHWDCONFIG exists.

I think to know now what the issue is:

  • since I updated mhwd-db those old drivers got invalid
  • so I should have done this:
    • use the old mhwd-db and remove the old drivers
    • update to the new mhwd-db and install the proper new drivers
  • I’ll have to rewrite it completely, as soon as I remove some profiles it doesn’t work

I’ll check all configs and write it completely manually, as currently it doesn’t work as expected.

This may be only tangentially related, but the nvidia.ids file seems to be lacking the id for the GeForce RTX 3060 Ti GPU (2486).
I suspect it’s kind of Nvidias fault for listing the support of said GPU under the release highlights, while not including it under the supported products. (Driver version 455.45.01)

Check if that helps:

I have the same error message on my Manjaro KDE machine. When checking /var/lib/mhwd/local/pci/ the only directory I have there is “video-nvidia-455xx”. On my machine, /var/lib/mhwd/local/pci/video-nvidia/MHWDCONFIG does not exist, so I probably should not delete the other file.

FWIW, I have these outputs:

nurunet > mhwd -li
Warning: config '/var/lib/mhwd/local/pci/video-nvidia-455xx/MHWDCONFIG' is invalid!
Warning: No installed PCI configs!
Warning: No installed USB configs!
nurunet > inxi -Gazy
Device-1: NVIDIA GP108 [GeForce GT 1030] vendor: Micro-Star MSI
driver: nvidia v: 455.45.01 alternate: nouveau,nvidia_drm bus ID: 26:00.0
chip ID: 10de:1d01
Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 driver: nvidia
display ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1440 s-dpi: 108 s-size: 602x342mm (23.7x13.5")
s-diag: 692mm (27.3")
Monitor-1: DP-0.8 res: 2560x1440 hz: 60 dpi: 109
size: 597x336mm (23.5x13.2") diag: 685mm (27")
OpenGL: renderer: GeForce GT 1030/PCIe/SSE2 v: 4.6.0 NVIDIA 455.45.01
direct render: Yes

Overall I have lots of issues with the proprietary driver (Kompositor crashing every time my machine wakes up from suspend, which regularly deactivates OpenGL) and Nouveau when I tested it (it did not handle the multi screen setup so well if I remember correctly).

Hi @nurunet,

As mentioned in this as well as several other threads, the ‘installer’/‘manager’/‘packager’ was changed to simplify NVIDIA drivers setup. The result being that I think those files can safely be deleted.

Getting the following error on the new manjaro-system update

Upgrading manjaro-system (20201231-5 -> 20210101-2)…
Error: manjaro-system: command failed to execute correctly
Running post-transaction hooks…
Arming ConditionNeedsUpdate…
Removing unnecessary cached files (keeping the latest two)…
removed ‘/var/cache/pacman/pkg/manjaro-system-20201231-2-any.pkg.tar.zst’

Okay, I deleted the video-nvidia-455xx/MHWDCONFIG file. I do indeed have the other file (video-nvidia/MHWDCONFIG). A restart was fine. I suppose I won’t know for sure until I get another update, but I suspect this solves it. Thank you everyone for the help!

1 Like

Thank you, I also confirm it is fine to remove the old file.
The nvidia driver name simplification did cause me some issues and hair-pulling but all fixed now, I hope…

I have not updated yet.
I began to investigate after pacman began throwing warnings when I tried to update only a couple of packages. (0AD and Firefox)

Just because upstream / OEM does not Support Legacy hardware anymore does NOT mean there aren’t a lot of people Still using legacy hardware.

Understanding their planned obsolescence model to force new sales explains why they drop support. ~ I think Apple & Microsoft pioneered it.
Most people do not need new, faster, hardware for general everyday use.
Laptop quality and resolution actually regressed when smart devices came out, with gaming and professional machines being the exception.

Yes this hardware is Legacy and therefore Does Not Change / does not need Hardware driver updates anymore. – If it ain’t broke, don’t fix it.
There is nothing wrong with these old machines, many are still floating around in constant use, selling on ebay and other places.
Not to mention that many people around the world cannot afford to buy new or upgrade.

What we do need is for maintainers to maintain legacy availability and stop hosing our systems just because _____ insert reason here. (drop 32bit /drop legacy/whatever.)
Everytime this happens the web gets flooded with searches.
Yes we all know nvidia sucks, but it is what it is and these are the cards we drew.

I’ve got New hardware that has less support than my old collection of laptops, desktops and datacenter servers that I still use as daily drivers and that is why I haven’t converted the new machines over to linux yet.

I understand that the kitchen sink is getting too damn big for the house and no distro can continue to drag all hardware ever made along for the ride as the monolith grows.
But that does not mean They (or you manjaro) have to drop support.
Hardware support should be Modular just like the kernel selection tool.

PLEASE provide a special section for legacy support in the repositories, forum, and website with errata and change logs to help us diagnose, debug and prepare so we can keep our old clunkers clunking along.

Thank you for your understanding, consideration and help!

Happy New Year!!

If you read Phils post here

Part of the problem is the gpl issue. Nvidia were doing some slightly unsavoury stuff with their gpl condom. Manjaro doesn’t want to be dragged into a gpl battle

1 Like

Interestingly, as of today, /var/lib/mhwd/local/pci/ is empty.

I am pretty sure I did not delete anything there.

1 Like has been modified by philm, to delete the files for you. So this is as it is supposed to be :slight_smile:

Turns out my issue was nvidia-utils. After uninstalling it, I could install video-nvidia and that worked.

Dropping support is one thing, but ripping drivers out of working systems is just plain malicious.
NOBODY does this, Not Apple, Not Microsoft, Not Google, Not RedHat, CentOS, Fedora, etc…
No, they just stop updating, block repositories, and other methods that do Not break systems.

I went to update One package and @philm mad MHWD scripts tore through my system with enforced Y and rendered it useless. – I was not given the option to decline.
I sure as hell wasn’t expecting that to happen!!

Where is the scruples guys?

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.