Mhwd installs outdated proprietary drivers

Short version:
What: mhwd detects and installs old version of nvidia driver(390xx)
Goal: Install the latest(4.6) one as my videocard is still supported, can I do it using mhwd in order to not mess up some configs?
Info: GeForce GTX660, kernel 5.10

A little bit of context:
I discovered this when trying to run a game via PoL and then switching to Lutris, it gave me an alert that my drivers are outdated, so I decided to use mhwd to automatically install them, however the version that it installed is video-nvidia-390xx, however the latest version which is for unix system of the driver listed in the nvidia website is 460.39. I’m using a GeForce GTX660 and it’s being supported by the latest version, however mhwd is automatically installing video-nvidia-390xx.
Note: I kind of understand how to manually install it from reading how-to-install-the-nvidia-drivers-on-manjaro-18-linux on linux config, but I prefer doing it via mhwd, if it is possible

Sorry for the noob question.

Try reinstalling the mhwd-db package. After that mhwd should show the latest one.


check your local mirrorlist status - if necessary update your mirrorlist

pacman-mirrors --status

then update your system (use double yy if you updated your mirrorlist)

sudo pacman -Syu

then use mhwd to install the primary driver packages

sudo mhwd -i pci video-nvidia
1 Like

Hi @Toni100Raro, and welcome!

As you probably know, you can view installed drivers with mhwd -li. Mine is:

$ mhwd -li
> Installed PCI configs:
NAME               VERSION          FREEDRIVER           TYPE
video-nvidia            2020.11.30               false            PCI

That is what it shows after there was a significant change to mhwd, last year December IIRC.

You can run nvidia-smi for more information on the card, it’s performance and it’ll show you which driver it’s using:

$ nvidia-smi
Fri Feb  5 13:58:17 2021
| NVIDIA-SMI 460.32.03    Driver Version: 460.32.03    CUDA Version: 11.2     |
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|   0  GeForce GTX 960     Off  | 00000000:01:00.0  On |                  N/A |
| 35%   33C    P0    34W / 130W |    522MiB /  1999MiB |      2%      Default |
|                               |                      |                  N/A |

| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|    0   N/A  N/A       677      G   /usr/lib/Xorg                     250MiB |
|    0   N/A  N/A      1084      G   /usr/bin/kwin_x11                 132MiB |
|    0   N/A  N/A      1157      G   /usr/bin/plasmashell               96MiB |
|    0   N/A  N/A      1195      G   /usr/bin/mntray                     1MiB |
|    0   N/A  N/A      1223      G   /usr/bin/akregator                  3MiB |
|    0   N/A  N/A      1225      G   /usr/bin/cairo-dock                 4MiB |
|    0   N/A  N/A      2059      G   ...gAAAAAAAAA --shared-files       19MiB |
|    0   N/A  N/A      2545      G   ...developer-edition/firefox        0MiB |

Note the Driver Version: 460.32.03 at the top there.

So, it is actually on the latest driver available, just not showing it in mhwd -li.

@linux-aarhus , @pobrn
Thank you, guys. the combination of reinstalling mhwd-db and sudo mhwd -i pci video-nvidia solved my problem. Wish I could mark two options as solutions, but I’ll give it to the first one. Again, thanks a lot.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.