Meta Button not working, and some programs not autostarting

Hey there,
I’m having some weird bug right now, where it seems that my pc won’t recognise meta key presses on my external keyboard (also not shortcuts that combine it with other keys), but it does recognise them on the laptop keyboard.
Also, some programs that used to auto start on boot won’t start automatically (KeepassXC, clight), although I have a script that I had configured to autostart in “system settings > startup and shutdon > autostart” which does run on startup.

It started when I noticed that the meta keyt wasn’t working, when in the shutdown sequence that was some USB error messages which stayed on screen for about a minute or two before it managed to shutdown.
On the first 2 startups the numlock key on the external keyboard wasn’t working as well, but after few other restarts it sorted itself out.
On one startup the autostart programs started after about 2 minutes, but they doesn’t seem to autostart now.

I tried to upgrade my kernel from 5.15.21-1 to 5.16.7-1 which didn’t seem to make a difference.
I doubt it is a hardware problem with the keyboard, as it started at the same time as the autostart stuff.

thanks in advance for any help!
(wasn’t sure if I shoud’ve posted it under kde or laptop categories, as I am running kde on a laptop…)

update: after some more testing - it seems that the “options” button (left of the right ctrl key) is also now recognised from the external keyboard, while it was in the past.

What kind of keyboard is it? Many keyboards include a “lock” function for the meta key, which is specifically helpful for playing games on Windows (some games will kick you out of the game to open the start menu if you press meta).

hey, thanks for the comment!
it’s a Redragon horus k618.
I’ve had it for a few months, and I don’t believe it has a meta lock, as Ive looked at all it’s features a few times and hadn’t seen anything related.
also - it doesn’t explain the software autostart issue.

According to your keyboard’s manual, FN+meta should toggle the meta key lock on and off.

If this is an unrelated issue, it is best to open a separate thread. Keeping issues separated makes it easier for people searching through the forum to find relevant information.

Wow, thank you so so much! it worked.
i never would have guessed it.
it also seems to have fixed the autostart bug (or maybe it is all just a big coincedence?)
this meta lock feature is definitly what happened here, and I guess it is somehow related to the autostart stuff?
in any case - it seems to have solved both issues (:

Thanks again!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.