Messed with BIOS, now can't mount

My touchpad scroll was not working so I went into BIOS to see if any settings were disabled. Well, like the newb that I am, I put my BIOS settings back to normal and checked to see if that worked. However, I am currently running a dual booted Acer spin 15 (Windows and Manjaro) and didn’t think about the consequences. Now I cannot boot into windows and I get the following message when trying to boot into Manjaro:

ERROR: Failed to mount ‘UUID=…’ on real root
You are now being dropped into an emergency she’ll.
sh: can’t access tty; job control turned off

When I try mounting from here with mount /dev/sda /mnt
I get no valid filesystem type specified

Any help would be appreciated.

Welcome to the forum! :wave:

Well, then go back and change things back to what make it work to begin with. :wink:

Tip: Look up your motherboard manual and review each setting to see what it does if you’re not sure.

I tried, but it hasn’t changed anything

Secure boot, CSM and RAID off and then reinstall grub

How do you know that he had CSM off before?

A valid point. It is far more probable but there’s no guarantee.