Messed up my system by accidentally creating mirrors from arch and installing them


I am using manjaro kde version. I tried to update my system and my system game me pacman error stating that can not find the local mirror in my country. I decided to generate mirror list and very late at night just before going to bed and I probably generated arch mirror list instead of manjaro from the a web site. pacman gave me error but stupidly, I found a command in a forum which I do not remember exactly, which includes overwrite and “*” that forces the installation of those packages. Now my system does not boot and gives kernel panic. I finally reliazed my mistake, boot to livecd and made manjaro-chroot, updated the mirror list, and now I receive bunch of “local is newer than” errors. I cleared the pacman cache. What can I do? I really hope or wish I do not have install from scratch.

I appreciate any help.

are these actual errors?

Does it work?
Or does it not?

and I probably generated arch mirror list instead of manjaro from the a web site.

It’s easy to check whether that is true.

What do you need help with?

Run pacman -Syuu to downgrade to the matching versions on the branch you’re on.

Tip: Don’t blindly run commands you find on the internet, especially when you’re tired. :wink:


I updated my mirror list in livecd environment after making manjaro-chroot -a.

I downgraded all packages and via pacman -Suu --overwrite "*", then I applied pacman -Syyu and received no errors and everything seems to up-to-date.

I reinstalled grub just incase

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck 
grub-mkconfig -o /boot/grub/grub.cfg  

My system now does not boot but it does not even reach to grub. I only see the computer manufacturer logo. I does not say, it can not find OS etc. It is stuck at logo.

Any help much appreciated.

Thank you. You are definitively right. I often read arch wiki. I never occured to me I using wrong mirrors.


I would like to add that I do not have a complex setup. I have only one ssd which is used fully as one drive for the installation. There are two small vfat partitions for /boot and /boot/efi and / root drive which f2fs.
I am using uefi boot.

@Yochanan, @Nachlese thank you all for the response.

I tried everything I found related grup restore, efibootmgr but nothing worked and decided to reinstall the system. I wanted to use lvm so I had to use manjor architect which was painful to use. Anyhow, after hours, I succeeded to restore everything back on a clean install with lvm. Thank you again.