Mesa Intel® UHD Graphics: After Update Wayland messed up LibreOffice fonts, but X11 is unstable

After update I tried Plasma Wayland first, which ran fine - except for LibreOffice (fresh) the letter in the canvas were very huge and I could not reduce its size at all.
Switching to X11 worked for LibreOffice just fine, but now X11 freezes randomly after ~15…30 min.
The mouse moves, but the clicks won’t work, while the keyboard works. Exception is I can’t switch windows with the keys.
After login again the same behavior reappears, after reboot it will stay ~1h before the freezing begins.

I would like to run Wayland, but I need LibreOffice … ?

Regards, Marcus

System:
ThinkPad L15 Gen 1
Intel i5-10210U CPU @ 1.60GHz with 16GB RAM,
Mesa Intel® UHD Graphics

inxi -F (partially)
System:
Host: IPT-Menzel Kernel: 6.6.30-2-MANJARO arch: x86_64 bits: 64
Desktop: KDE Plasma v: 6.0.4 Distro: Manjaro Linux
Machine:
Type: Laptop System: LENOVO product: 20U3000QGE v: ThinkPad L15 Gen 1
serial:
Mobo: LENOVO model: 20U3000QGE v: SDK0J40697 WIN
serial: UEFI: LENOVO v: R17ET31W (1.14 )
date: 08/13/2021
Battery:
ID-1: BAT0 charge: 34.5 Wh (91.0%) condition: 37.9/45.0 Wh (84.2%)
CPU:
Info: quad core model: Intel Core i5-10210U bits: 64 type: MT MCP cache:
L2: 1024 KiB
Speed (MHz): avg: 4022 min/max: 400/4200 cores: 1: 3902 2: 3900 3: 3900
4: 4143 5: 4079 6: 4094 7: 4059 8: 4105
Graphics:
Device-1: Intel CometLake-U GT2 [UHD Graphics] driver: i915 v: kernel
Device-2: Bison Integrated Camera driver: uvcvideo type: USB
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6 driver: X:
loaded: modesetting dri: iris gpu: i915 resolution: 1: 1920x1080
2: 1920x1080~60Hz
API: EGL v: 1.5 drivers: iris,swrast platforms: x11,surfaceless,device
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.0.6-manjaro1.1
renderer: Mesa Intel UHD Graphics (CML GT2)
API: Vulkan v: 1.3.279 drivers: intel surfaces: xcb,xlib
Audio:
Device-1: Intel Comet Lake PCH-LP cAVS driver: snd_hda_intel
Device-2: Lenovo ThinkPad USB-C Dock Gen2 USB Audio
driver: hid-generic,snd-usb-audio,usbhid type: USB
API: ALSA v: k6.6.30-2-MANJARO status: kernel-api
Server-1: PipeWire v: 1.0.5 status: active