Menu bar/plasmashell dissapeared after update

After current update my menu bar dissapeared, i even used timeshift to go back on my files.
I tried to google this problem, to no avail.

I’ve tried to use default theme and removed widgets (at least tried).
This is what plasmashell prompts:

kf.plasma.quick: Applet preload policy set to 1                                                                                                                                                      0 [23:10:04]
"file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/views/Desktop.qml" 
 "Error loading QML file.\n13: plugin cannot be loaded for module \"org.kde.plasma.activityswitcher\": Cannot load library /usr/lib/qt/qml/org/kde/plasma/activityswitcher/libactivityswitcherextensionplugin.so: (/usr/lib/libtaskmanager.so.6: undefined symbol: _ZN8KWayland6Client16PlasmaActivation13applicationIdERK7QString)\n"
Could not set containment property on rootObject
"file:///usr/share/plasma/shells/org.kde.plasma.desktop/contents/views/Panel.qml" 
 "Error loading QML file.\n12: plugin cannot be loaded for module \"org.kde.taskmanager\": Cannot load library /usr/lib/qt/qml/org/kde/taskmanager/libtaskmanagerplugin.so: (/usr/lib/libtaskmanager.so.6: undefined symbol: _ZN8KWayland6Client16PlasmaActivation13applicationIdERK7QString)\n"
Could not set containment property on rootObject
inxi -Fxxx                                                                                                                                                                                           0 [23:44:41]
System:    Host: manjaroOSs Kernel: 5.10.79-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.23.3
           tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:   Type: Convertible System: ASUSTeK product: VivoBook_ASUSLaptop TP420IA_TM420IA v: 1.0 serial: <superuser required>
           Mobo: ASUSTeK model: TP420IA v: 1.0 serial: <superuser required> UEFI: American Megatrends v: TP420IA.302
           date: 09/04/2020
Battery:   ID-1: BATT charge: 19.2 Wh (55.5%) condition: 34.6/41.9 Wh (82.6%) volts: 11.8 min: 11.8 model: ASUSTeK TP420
           type: Li-ion serial: 123456789 status: Discharging cycles: 421
           Device-1: hid-0018:04F3:2BC8.0001-battery model: PNP0C50:03 04F3:2BC8 serial: N/A charge: N/A status: N/A
CPU:       Info: 8-Core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP arch: Zen 2 rev: 1 cache: L1: 512 KiB
           L2: 4 MiB L3: 8 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31949
           Speed: 1462 MHz min/max: 1400/2000 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1397 5: 1397
           6: 1397 7: 1397 8: 1397
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Renoir vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 03:00.0
           chip-ID: 1002:1636 class-ID: 0300
           Device-2: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo bus-ID: 1-3:2 chip-ID: 13d3:56a2
           class-ID: 0e02 serial: 0x0001
           Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati unloaded: modesetting
           alternate: fbdev,vesa resolution: 1920x1080~60Hz s-dpi: 96
           OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.10.79-1-MANJARO LLVM 13.0.0) v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] vendor: ASUSTeK driver: snd_hda_intel v: kernel bus-ID: 03:00.1
           chip-ID: 1002:1637 class-ID: 0403
           Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor vendor: ASUSTeK driver: N/A
           bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
           Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Device-4: Logitech PRO X type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-2:3 chip-ID: 046d:0aaa
           class-ID: 0300 serial: 000000000000
           Sound Server-1: ALSA v: k5.10.79-1-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: no
Network:   Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus-ID: 01:00.0 chip-ID: 8086:2723 class-ID: 0280
           IF: wlp1s0 state: up mac: dc:41:a9:d7:72:92
           IF-ID-1: pan1 state: down mac: 7a:be:e1:a3:d2:c3
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-4:2 chip-ID: 8087:0029 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: DC:41:A9:D7:72:96
Drives:    Local Storage: total: 476.94 GiB used: 82.36 GiB (17.3%)
           ID-1: /dev/nvme0n1 vendor: Kingston model: OM8PCP3512F-AB size: 476.94 GiB speed: 31.6 Gb/s lanes: 4 type: SSD
           serial: 50026B7683A980D1 rev: ECFK52.3 temp: 37.9 C scheme: GPT
Partition: ID-1: / size: 114.48 GiB used: 82.33 GiB (71.9%) fs: ext4 dev: /dev/nvme0n1p6
           ID-2: /boot/efi size: 256 MiB used: 32.2 MiB (12.6%) fs: vfat dev: /dev/nvme0n1p1
Swap:      Alert: No swap data was found.
Sensors:   System Temperatures: cpu: 42.9 C mobo: 42.0 C gpu: amdgpu temp: 42.0 C
           Fan Speeds (RPM): cpu: 0
Info:      Processes: 278 Uptime: 41m wakeups: 2864 Memory: 15.11 GiB used: 3.26 GiB (21.6%) Init: systemd v: 249 Compilers:
           gcc: 11.1.0 Packages: 1409 pacman: 1406 flatpak: 3 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 running-in: yakuake
           inxi: 3.3.09

Any ideas?

Much appreciated!

Looks like the culpit is kwayland-git :frowning:
I have no idea why i have it installed, any safe way to delete kwayland-git and its dependecies?

I need to reinstall plasma-desktop i guess.

Looks like i should stop using -git AURs in the future:

adapta-kde-git r180.ae539ff-1
akava-colors-git r10.9a49c6f-1
ant-dracula-kde-theme-git v2.0.r47.g502f212-1
cherry-kde-theme 1.3.r6.gd0e7045-1
discord_arch_electron 0.0.15-1
flameshot-git r1369.6a54285f-1
github-cli-git 1.13.1.r24.gfbdebe8e-1
intellij-idea-ultimate-edition 2021.2.1-1
jdk-doc 16.0.2-2
jetbrains-toolbox 1.21.9712-1
jumpapp-git 1.1.r108.c3cda40-1
konsole-git 19.12.3.r903.g99b395946-1
kvantum-theme-arc 20180614-3
lightworks 2021.2-1
linux512 5.12.19-1
linux512-virtualbox-host-modules 6.1.26-1
linuxed-git 0.r111.6c539f3-1
mcmojave-circle-icon-theme-git 2020.10.11.r25.6b43ee35-1
obs-studio-git 27.0.1.r182.gcb317f2b3-1
papirus-icon-theme-git 1:20210802.r59.g1cb0a07d11-1
plasma-theme-moe-git r20.4c1f4df-3
pulseaudio-modules-bt 1.4-6
sdx 20110317-1
simplescreenrecorder-git 0.4.3.r31.gc934aed-1
spotify 1:1.1.56.595-1
swayshot 2.6.0-1
sweet-kde-theme-mars-git r157.d8f1d4a-1
tclkit 8.6.11-1
telegram-desktop-bin 3.0.1-1
ulauncher 5.11.0-1
ulauncher-theme-arc-dark-git r7.3083ea2-1
visual-studio-code-bin 1.59.0-1
volantes-cursors 20200506.0-2
xampp 8.0.9-1
yakuake-git 21.11.70_r729.g7053b39-1
yakuake-skin-breeze-perfect-dark 2.0-1
youtube-music-bin 1.12.2-1
zoom 5.7.4-1

Timeshifted back before update, then:

pacman -Rdd kwayland-git 

And at the end sudo pacman -Syyuu
Now the panel is there.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.