Mediatek mt7921 Issue

Hi everyone I’m new to linux and just installed manjaro kde recently. I’m using an asus vivbook with an mt7921 network adaptor which won’t work . Hadware configuration in system settings lists the network adapator as an unknown mediatek device. It worked fine previously on windows before I installed linux so i know the card is functioning. The bluetooth is working but I keep it disabled.I’m using the latest 5.16 kernel and I’ve made sure everything is up to date including the network manager. I also tried installing some of the mt76 packages from aur using pamac and then restarting the computer but none of of the ones I tried were compatible. Is there anything more I have to do after building a package in pamac to get it working or are drivers automatically installed and working with each build? Right now I’m making do with a wired connecting where I run an ethernet to usb adaptor to the computer but I’d really like to get wifi working.


I just switched my laptop on and the wifi card was working. I was able to connect to the internet with wifi though I’m not entirely sure what fixed it. It might be that I switched the laptop on with the ethernet cable disconnected.