Media keys wont work after reopening music player

I dont know what the reason for this happening is. When i add a new media player widget or restart plasmashell while the player is open it seems to fix itself but when i reopen the player it break again. I tried multiple apps and all of them seems to have the same problem. When i removed the keybinds in System Settings for media controller it worked fine for vlc. Heres information for my inxi :

System:
  Kernel: 5.15.76-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=875edbad-ad77-49d2-ac56-e609bdfda3a8 rw quiet resume=/dev/sda8
    udev.log_priority=3
  Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.6 info: latte-dock
    wm: kwin_x11 vt: 1 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Audio:
  Device-1: Intel 5 Series/3400 Series High Definition Audio vendor: Dell
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:3b56
    class-ID: 0403
  Sound API: ALSA v: k5.15.76-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: no