Mce: [Hardware Error] on startup

Hello, So, Everytime I startup my laptop, the following message shows for a few seconds and then I see the login screen as usual. The message doesn’t cause any problems except for time delay of approximately 10-15 seconds on EVERY STARTUP. What does it say or is there any way to fix it?

I run Manjaro Linux on my Dell Inspiron laptop as the ONLY OS on the machine.

Welcome to the forum! :slight_smile:

Machine checks are a hardware problem, not a software problem. They are often the result of overclocking or overheating. In some cases, the CPU will shut itself off once passing a thermal limit to avoid permanent damage. But they can also be caused by bus errors introduced by other failing components, like memory or I/O devices. Possible causes include:

  • Poor CPU cooling due to a CPU heatsink and fan that’s clogged with dust or has come loose.
  • Overclocking beyond the highest clock rate at which the CPU is still reliable.
  • Failing motherboard.
  • Failing processor.
  • Failing memory.
  • Failing I/O controllers, on either the motherboard or separate cards.
  • Failing I/O devices.
  • Inadequate or failing power supply.
  • Poor general case cooling due to inadequate or clogged case fans or filters.

As stated, it doesn’t cause any problems with any normal usage. So, why does it even show, that too for only few seconds.
Also, I have 64bit i5 processor, not pentium as stated in the artice.

Just because it isn’t causing any problems now doesn’t mean that it won’t be causing any problems in the future.

Obviously, it is a hardware error. What you do with it is your decision. :man_shrugging:

So what hardware changes should I do?
The laptop is 1.5 years old, and hardware problems so early?

In your case I would try some kernel parameters. They can be changed by:

  1. Use nano to edit /etc/default/grub: sudo nano /etc/default/grub
  2. Add the kernel parameter you want inside the quotes to the line starting GRUB_CMDLINE_LINUX_DEFAULT=
  3. Save the change by pressing CTRL+O together. Then exit with CTRL+X.
  4. Update grub with sudo update-grub

In your case I would test the kernel parameters

mce=off

and

mce=nobootlog

https://www.kernel.org/doc/Documentation/x86/x86_64/boot-options.txt

1 Like

Considering that overheating is often a cause ─ albeit not the only possible cause ─ you might want to clean out the fans. It may also be faulty memory ─ such faults don’t always show up when the module is new.

If it’s a faulty memory module, you could run memtest86+ and let it run for about 24 hours. Then you’ll know which module it is.

1 Like

OK, thanks @Aragorn and @Wollie.

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.