Mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 5

I installed the stable update today with the pamac GUI als I always do, but unfortunately it resulted in a major error: on the reboot my laptop got stuck on an error message stating:

[    0.245300] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 5: ae00000000
[    0.245300] mce: [Hardware Error]: TSC 0 ADDR fef873c0 MISC 78a0000086
[    0.245300] mce: [Hardware Error]: PROCESSOR 0:40651 TIME 1680276004 SOCKET 0
 APIC 0 micronode 26
[    0.438308] Initramfs unpacking failed: invalid magic at start of compressed
[    0.679173] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    1.125084] CPU: 2PID: 1 Comm: swapper/0 Not tainted 5.4.238-1-MANJARO '#1
[    1.127377] Hardware name: LENOVO 20354/Lancer 5A5, BIOS 9BCN25WW 04/10/2014
[    1.129729] Call Trace:
[    1.130559]  dump_stack+0x64/0x7c
[    1.131671]  panic+0x11a/0x30d
[    1.132698]  mount_block_root+0x2e2/0x306
[    1.134044]  prepare_namespace+0x136/0x16c
[    1.135418]  ? rest_init+0xbf/0xbf
[    1.136556]  kernel_init+0xa/0x101
[    1.137696]  ret_from_fork+0x35/0x40
[    1.138939] Kernel Offset: 0x29e00000 from 0xffffffff81000000 (relocation range: 0xffffffff80000000-0xffffffffbfffffff)
[    1.142537] ---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0( ]---

(this is NOT an exact copy of the error output, since I was not able to do anything while that happened. I typed it manually with my hands in here from a photo that I took of the error output - also I am typing this now from a live-usb and have a wrong keyboard setting, so it was a pain in the ass to type it haha and since i could not type a # without getting automatic fill ins, I put the ’ before it. that was not there in the original message. also the amount of spaces might not always be correct, I just tried to make it optically look as much like the original as possible):

Before that update everything worked fine, I had no issues at all.
I am not really fit with IT but I was using Manjaro for the past 4 years without ever having to deal with serious trouble like this (minor problems i could always solve with help of the forum or friends). I read some threads in the manjaro forum about Kernel panic issues but the explanations were too complicated for me to execute. I asked a friend to help me out and he tried to apply a tip from a thread from ne_vanrijn from June 2021 who seemed to have the same issue with almost the same error message but we could not make it work/solve the problem this way…

Does anybody have a solution/idea, that I could try (fairly easy, understandable step-by-step without requiring deeper skills or insights) or do I have to set up my system completely new and wipe everything?

Thanks in advance for any tips!

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Hello @MarMJ and welcome!

The problem is actually this: mce (Machine Check Exceptions) detected an error on one of your RAM modules, which was not able to be corrected. Commonly it always tries to correct it, but on non-ecc RAM it is not easy. These errors can come and go, and are a result of old-aged RAM modules. It is not easily to determine for example which RAM module is affected.

In this message it says just, that on CPU 0 (or Core 0) happens that on Bank 5 (one of the ram module) an uncorrectable error happens when allocating ae0000000040110a.

In any way, it could be the RAM module or the CPU, but commonly it is a defective RAM. :man_shrugging:

Sometimes it helps to eject the ram, and to re-plug it into its slot.

Thank you so much for your reply! So you think that the kernel panic issue was caused by the RAM error? Or are there actually two different problems? And is there an explaination why this happened only after the latest update? Up until the update, everything seemed to work fine…

Allright, do you know where I can get info in how to do this? I’ve never ejected a RAM before…and currently I can not enter my system since it doesn’t Boot…so i would have to do this from a livestick (my friend gave me one with Endeavor OS on it, because that is what he is using)
And would it help to wipe the system and install manjaro fresh again? Or would manjaro always get stuck in this RAM error, even if it is a fresh install?

Thank you so much for helping out!!

This is a physical hardware process, getting ‘in to your system’ will mean opening the case;.
There are 2 types of ram modules, laptop and full size, both are easy to put in and out (laptop example:, getting to some laptop ram modules, however, can be tricky. Tell us the model of your PC and we can give you more info.

1 Like

I have a LENOVO Z50 laptop and got it in October 2014.

MCE errors can be resulting from BIOS/software interactions so first and easiest step would probably be to update BIOS before making hardware changes like ejecting and cleaning RAM. The RAM error might very well be phantom. I had similar issue when i bough the very latest ryzen2 on the new x58 motherboard, but a BIOS update fixed it.

1 Like

Maybe the mce is not the real problem

Please also look into:

What kernel did you use ? 5.10 ? (inxi would be helpful)

Welcome to Manjaro! :smiling_face_with_three_hearts:

  1. Please read the information behind this link. It will help you to post necessary information.

[HowTo] Provide System Information

  1. Please press the three dots below your post and then press the :pencil2:
  • If you give us information about your system, we can see what we’re talking about and make better suggestions.
  • You can do this by using inxi in a terminal or in console.
sudo inxi --admin --verbosity=7 --filter --no-host --width
  • Personally identifiable information such as serial numbers and MAC addresses are filtered out by this command
  • Presenting the information in this way allows everyone to be familiar with the format and quickly find the items they need without missing anything.
  1. Copy the output from inxi (including the command) and paste it into your post.
  • To make it more readable, add 3 backticks ``` on an extra line before and after the pasted text.

(Wisdom lies in reading :wink: )

1 Like

Oh, that is also an interesting hint…

Good memory access: Lenovo Z50 laptop memory upgrade tutorial - YouTube . Even if your current problem is fixable via the above tips it’s a good info should you ever consider maxing the ram to 16GB.

1 Like

Ah yes, that seems to be a similar Problem…maybe i can find someone to help me try this…i had so little issues for the past years with manjaro that i am just really a bit overwhelmed by this complicated problem…but really appreciate the help of all of you!!!

(And yes, i made a mess of my post…should have read the part with the formatting and tried to get the inxi output while i was on the livestick…will try to do better next time! Guess i was just so stessed and freaked out that my mind just didn’t work properly :confused: )

Great! That is a helpful info in any case, although i will try the other solutions first i guess…

I have among other things a gigabyte brix - same error message
it comes because of an error in the bios - the device has no mce controller at all
And the “error” had no consequences since 2017.

1 Like

This was it! Now my laptop boots normally again. And I also saw that there was already an Update for the mkinitpcio package now that probably would have solved it as well… :slight_smile: Thank you all, this was really helpful! You are doing an amazing job with Manjaro :slight_smile:

Just as an additional info: i was using kernel 5.4 and didn’t realise that i obviously had not updated it in a while…did update to 6.1 now. That might have solved the problem as well without manipulating the mkinitpcio package…
Anyway, now i learned some things and i am happy that i can fully enjoy my manjaro again :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.