MC (Midnight Commander) no mouse actions with konsole

with an older manjaro system I’m able to execute mouse actions in MC, but here only a cursor is shown no pointer

installed & updated from:

GPU driver:
linux: 5.15

does anyone have any idea how to solve this issue?

Operating System: Manjaro Linux
KDE Plasma Version: 5.25.5
KDE Frameworks Version: 5.98.0
Qt Version: 5.15.6
Kernel Version: 5.15.74-3-MANJARO (64-bit)
Graphics Platform: X11
Processors: 8 × AMD FX™-8350 Eight-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: NVIDIA GeForce GT 630/PCIe/SSE2
Manufacturer: MSI
Product Name: MS-7641
System Version: 3.0

mc can be fully controlled via keyboard
in xorg and wayland, when run in a terminal, the mouse can also be used

But somehow I don’t think that this is what you mean.
The term “mouse actions” in the context of KDE probably means something I don’t even know what it is.

In TTY, the mouse is only available when you also configure gpm and start and have the service running.

1 Like

Thank you for reply!
I have checked the other (older) system where I can click the MC menu buttons via mouse, there is no gpm.service enabled, but it works

sudo systemctl status gpm.service
○ gpm.service - Virtual console mouse server
     Loaded: loaded (/usr/lib/systemd/system/gpm.service; disabled; preset: disabled)
     Active: inactive (dead)

the new installation does show a mouse pointer in MC, also after activating the gpm.service, mc can only used via keyboard …


xcursor-vanilla-dmz is in use

tail -n 500 /var/log/Xorg.0.log | grep -e WW -e EE
[     7.523] Current Operating System: Linux hounddog 5.15.74-3-MANJARO #1 SMP PREEMPT Sat Oct 15 13:39:11 UTC 2022 x86_64
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     8.473] (II) Initializing extension MIT-SCREEN-SAVER

this is only needed/intended for when you are in a TTY → not in a graphical session

I have no idea why the mouse would not work when mc is run in a terminal.

You could try a different terminal instead of Konsole - but I have used Konsole and it worked as in every other terminal app.
Some (mis)configuration, perhaps - no idea. I do not have KDE at the moment. But mc has always worked in any DE.
I very rarely use the mouse in mc, so I might not have noticed whether it was working or not.

1 Like

you’re right, it works in xterm and yakuake …hmm, it seems to have something to do with Konsole…

Thank you! I have deleted the configuration folder and files of konsole, now it works :wink:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.