Maximum Amount of Locked Memory?

I have a PC running Manjaro with XFCE, and stumbled upon a new error trying to run a newly installed Ardour:

"WARNING: your system has a limit for maximum amount of locked memory. This might cause Ardour to **run out of memory before your system runs out of memory**

You can view the memory limit with 'ulimit -l'. and it is normally controlled by /etc/security.conf'

since it’s my first time seeing anything like this, I went to check security.conf but it’s content is entirely disabled (all lines start with # so the code should be skipped)

that PC has 8Gb RAM, and all other software runs without issues.

Any idea is welcome!

If you want to disable security limit entirely, uncomment or add this to your conf:

@audio - memlock unlimited

Or rather … it would be better to create a file with that content at

You can also use a number like 4096 (4gb) instead of ‘unlimited’)

(Note … most likely your issue is coming from the @users - memlock 1024 line in /etc/security/limits.d/10-gcr.conf)

PS - oh. also there are packages like realtime-privileges you might be interested in, which might take care of this and other things if you are doing realtime audio processing.

thanks a lot for the tips, will try and report back asap!

okay, I tried everything you suggested (including installing "realtime-privileges package) but nothing seems to be effective, the same error still shows up :frowning:

is your user a member of the audio group?

1 Like

done, now the error message doesn’t show anymore. Thanks a lot for the help :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.