Maximize Window (Meta+PgUp) not working as expected. How can I fix that?

I installed Manjaro (stable) fresh a few weeks ago with KDE Plasma (currently 5.27.11). I had used GNOME before and took care to only copy relevant settings over anyway (the idea was to distill those settings I care about from those that accumulated over time).

Ever since, the functionality to Maximize Window did not work. The best I get with Meta+PgUp is that the window fills the upper half of the screen.

Here are the relevant settings, which seem to be okay.

I am using custom keyboard layouts, but PgUp and PgDn are not subject to change in those. I write this, because some of the diacritics which I have added in my keyboard layouts have in the past shadowed keyboard shortcuts of programs. But again, this shouldn’t be the case here.

Could anyone tell me:

  1. whether my understanding of the functionality of Maximize Window is correct in that it is supposed to fill the whole working area of the current screen, not just the upper half?
  2. how to go about to diagnose why these shortcuts don’t work?
  3. how to fix the issue at hand? (probably evident when the “why” has been found)

FYI: when I press Meta+PgUp once, the window takes the full width of the screen, but only half its height, glued to the top. When pressing Meta+PgUp again the window gets restored to its previous size and position.

PS: I have seen this thread (since it’s a fresh installation I don’t see how the profile could be borked already) and this thread but neither one provide a solution that works for me.

Since you said you’d copied some Gnome settings over, that’s the first place I’d look. I’d try creating a new user account with default settings and see if you get the same behaviour there.

HTH :slight_smile:

Are you sure you are not clicking on up key instead of page up key?

Meta+Up: Tile window to top.

Meta+ PgUp: Maximize window.


Caught me. That’s a clear case of PEBKAC. Thanks!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.