MATE Panel Clock Applet Gone

Post update my Panel clock was gone, and there’s no way to Add (Panel right-click, Add to Panel…) it back. Here’s the error popup:

I’ve searched this site for a post mentioning exactly that issue that I’d seen a few days ago from user Raj. That post had no replies and was moved to this Support area as I recall, but I’m unable to find it to see if anyone ever responded. That post title I think began with “Testing…” and noted that Clock and two other MATE Panel applets (I don’t use those) didn’t work post update.

I’m using MATE primarily because my wife uses Ubuntu MATE so I put it on all of our computers, and my PC’s the only one with Manj-MATE. The others are all working normally fwiw, so hopefully that continues so I can have time to fix this one. :crossed_fingers:

Any ideas or suggestions are most welcome.

My system:
Core i5-9400, 11.4G, UHD630
MATE1.28.2, X11, Manjaro 6.6.32-1

This user has a total of 2 posts and they are about KDE from 1 year ago.

I might guess a local config then.
Have you tried with a new user, if only to test ?
(if it works there … then something in your HOME would be at fault like in ~/.config)

1 Like

Hello @j4u , try this: Install dconf-editor and restart.

I also encountered the same error with OpenSuse Tumbleweed.
See here:

and here:


1 Like

I hadn’t realized there’s a posting minimum to consider. My problem is that I know very little about Manjaro, and have become less conversant in all Linux topics as age seems to be having more effect. Thanks for what I gather is your encouragement to further consider switching my computer to Ubuntu.

I imagined having posted on other topics here, but as to that one it may have been asking if KDE or the other Manjaro flavors would be better than MATE (which I wondered again when the clock disappeared). :wink:

Ah! At your kind suggestion I took a look in that directory and was startled at how many subdirectories had built up there in my early explorations of ManjMATE. I wonder if the KDE apps in particular might be problematic (I hope not, because I’d sorely miss Nemo’s “Pin” feature). I gather that a test User would reveal conflicts in ~.config along with other possibilities?

Here’s the contents of ~.config/ (71 items - looks pretty bloated!)
atril, audacious, audacity, autostart, blender, brasero, caja, darktable, dconf, deepin, dsg, falkon, gconf, ghb, GIMP, gnome-mplayer, gogglesmm, gthumb, gtk-2.0, gtk-3.0, gtk-4.0, hexchat, kate,, KDE, Kvantum, libreoffice, manjaro, mate, mate-menu, mate-session, Meltytech, menus, nemo, onlyoffice, pamac,, plank, pluma, pulse, qt5ct, session, strawberry, transmission, vlc, yelp

digikamrc, digikam_systemrc, dolphinrc, elisarc, katemetainfos, katerc, katevirc, kbackuprc, kconf_updaterc, kdeglobals, khotkeysrc, knfsshare, konsolerc, kritadisplayrc, kritarc, kwriterc, manjaro-hello.json, mimeapps.list, monitors.xml, QtProject.conf, showfotorc, showfoto_systemrc, Trolltech.conf, user-dirs.dirs, user-dirs.locale

Thanks for these suggestions. I’ll follow up tomorrow if possible (so many pressing things lately!).

Hi snydar :slightly_smiling_face:it

Yes! I’d seen other mentions of dConf in searching the Forum here, but didn’t think it would apply since I always install it on Linux systems (currently it’s dConf Editor 45.0.1). Just now I tried to Un/Re-install it with Add/Remove Software in case that might work, and got this error:
I hesitated to uninstall dconf-editor first in case that could make matters worse. Would you suggest I take a screencap of my ~31 item Panel and then try it (presumably with pamac)?

I’ve been using it trying to find where the clock applet actually is, but perhaps luckily it hasn’t helped. A side note I found interesting is that dConf once displayed several Panel Objects containing Clock applets, apparently left behind by my attempts to reinstall the clock when it vanished (sadly, I’ve been unable to find that very helpful list of all the Object contents again).

While much of that’s beyond me at first glance, I’m very glad to know it’s a somewhat common problem. Misery loves company I guess. :wink:


Ok, then dconf-editor was already installed. Too bad, I thought that would help.

Since 2024-04-22, Mate is no longer really supported:

Notable Package Updates
We dropped various packages related to unmaintained community editions; i.e, Awesome, Bspwm, Budgie, Deepin, MATE, Openbox, etc.)

Maybe give XFCE a chance? :slight_smile:

1 Like

Wow, thank you so much for the MATE news snydar! Makes perfect sense from a dev workload perspective. It may foretell doom for UbuMATE too so, atop everything else, maybe a major multi-computer multi-week upgrade looming for me. :crazy_face:

It does not.
It only means that the manjaro team is not keeping links to old ISOs or continuing to provide any specific packages (something like manjaro-mate-settings).
It has no real impact on Mate overall (you can still use it at least as much as you would be able to run Mate on Arch).
It certainly has absolutely no impact on other Distros or the development of the Mate DE itself.

I suggested creating and logging in to a new user to observe the clock function there.

1 Like