MATE: how can i switch off "recently used files" and "remember-app-usage"?

dear all,
how can i switch off the “recently used files” and “remember-app-usage” in MATE-Desk permanently?

for example in Firefox: if i choose to open a file with “strg o” i get the whole list of documents (txt, pdf, doc), pictures, music and video files that i had opened by double-clicking in the CAJA file manager.

i found a solution to manually delete the file “recently-used.xbel” in the “.local/share”-directory.

this file is generated automatically with every new login, and after opening new files all the new files show up in the new “recently-used” file again. so this is no permanent solution.

in DCONF-editor i found parameters for GNOME (not MATE), which i changed, but these are NOT respected by MATE:

- old-files-age: 0 
- recent-files-max-age: 0 
- remember-app-usage: OFF 
- remember-recent-files: OFF 
- remove-old-temp-files: ON 
- remove-old-trash-files: ON

in DCONF-editor i found NO corresponding settings like:


i also searched in the Ubuntu-Mate-Forum and there was mentioned that the Ubuntu-DCONF-editor has these corresponding Mate-settings.

so i assume that there are different versions of DCONF-editor in Manjaro and Ubuntu.

would anyone know how i could permanently switch off the “recently used files” and “remember-app-usage” in our MANJARO MATE-Desk?

i am a NOOB and would need a rather easy solution…

if you know any other non-needed functionalities to switch off, then please suggest them also here.

Big thanks!

Once you delete the file, create a new folder in there, and name it recently-used.xbel so the new file will not be created automatically. Or you make create a dummy file with:

touch recently-used.xbel

then make the file immutable with:

sudo chattr +i recently-used.xbel

All this you do in ~/.local/share/
As for the

are you referring to mate-session-save as part of the mate-session-manager ? Well, check those settings …

Regardless, both do the same thing, but for Gnome, not for other DE.

Big Big Thanks !!!
i think your method to create a dummy file in ~/.local/share/ and make it immutable is perfectly the solution i was looking for!

touch recently-used.xbel

sudo chattr +i recently-used.xbel

if its recommendable to keep the system clean, with DCONF-editor i also just set the thumbnailers to not save any data:

org/mate/desktop/thumbnailers/disable-all: YES 

org/mate/desktop/thumbnail-cache/maximum-age: 0

regarding app-usage: i assumed that every usage of applications (terminal, caja file manager, eye-of-mate, pluma text editor, firefox, VLC, etc.) might be saved somewhere too.
but i dont have knowledge about
mate-session-save or mate-session-manager
and i did not find any specific settings for it.

1 Like

i would have one more question:
the command for changing attribute does not work when i am logged into the second user account (not the administrator account)

it asks for the administrator password, but then it denies it, and keeps the file writable.

what can i do here?

On your second user, if it can’t invoke sudo it means is a standard user, and not in the wheel group. Copy as root the file from your user 1 that works to the user 2.
Other than that, no idea about those apps. Maybe someone will chime in with an answer for that.

The following worked for me:
Put the following in ~/.config/gtk-3.0/settings.ini (create the file if it doesn’t exist):


Then, remove the file holding recently-used data:
rm ~/.local/share/recently-used.xbel

The recently-used.xbel file got recreated after deletion with this content:

<?xml version="1.0" encoding="UTF-8"?>
<xbel version="1.0"

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.