Mate Desktop Icons Intermittently Disappear

I’m running Manjaro Mate (since late Dec 2021), and recently (the last 5 days or so) my desktop icons (“Computer”, “Network Servers”, “Home”, mounted volumes, etc) have been intermittently disappearing. One moment they’re there, the next moment they’re not. Sometimes going into “Mate Tweak” and turning “show desktop icons” off then back on will solve the problem, sometimes not. Sometimes I have to restart the computer, then turn the icons off then back on to make them show up.

So, what could be causing this?

It’s almost as if the desktop background is being painted on top of the icons instead of under the icons (I’ve seen a bug like that in Windows where tooltips were being painted underneath toolbars where they can’t be seen).

Whatever it is, it isn’t having any effect on the bottom pop-up panel or its menu, icons, and applets; those all work fine.

1 Like

I’m running Manjaro Mate, and my desktop icons have now all disappeared completely. What is happening, why, and how can I fix it? (I tried going into “Mate Tweak” and turning “desktop icons” on and off, but that is not helping.)

(I asked about this problem 5 days ago, when the problem was still intermittent, but I got no replies. But now my desktop icons have disappeared completely and I’ve been unable to reinstate them at all.)


Really sorry for the inconvenience, but creating duplicate posts will not help.
Also see Forum Rules - Manjaro

One thing you can test is to run:
gsettings set org.mate.background show-desktop-icons true
killall caja

But if is not caja set to handle the desktop icons then MATE - ArchWiki might be helpful.
Probably removing the ~/.config/caja directory in your home and going into the ~.config/autostart directory and if there are any caja.desktop* files in there to also delete them, or make a backup first. Log out and log back in and see if that makes a difference.

Ahoy, bogdancovaciu, and thanks for the reply.

I managed to get desktop icons back for a while by creating new files, changing desktop icons in “Appearance Settings”, and repeatedly turning desktop icons on and off in “Mate Tweak”. (I’m not sure which (if any) of those were what actually did the trick.)

But on restarting my computer, the icons are off again.

And, I just noticed that my desktop has one other problem: Right-clicking the desktop does nothing (no menu pops up). It’s like the desktop isn’t actually there. The background picture is, but it isn’t functioning as a desktop. What could be causing that?

I ran:
%gsettings get org.mate.background show-desktop-icons

So that setting isn’t the issue. (But then, I didn’t expect it would be, as the “Mate Tweak” GUI is probably just a wrapper around that, no?)

I tried “killall caja” but I get:
%killall caja
caja: no process found

I would not have thought of Caja in regards to desktop functionality. How can I ascertain whether it’s set to “handle desktop icons”?

I moved all all files from “~/.config/caja” to “~/cut/.config/caja”, and ascertained that there are no caja-related files in “~/.config/autostart”, then logged out and back in, but the problem persists (no icons, and right-clicking desktop does nothing).

Update: I found the proximate cause of this problem! Your mention of Caja as a possible controller of the desktop, combined with the fact that typing “killall caja” yielded “caja: no process found”, got me to thinking: What is wrong with this picture? No Desktop… Caja controls desktop… no Caja… so of course no Desktop. So I launched an instance of Caja from my menu, et voilà, Desktop is back!

So I shut down the computer, waited 10 seconds, restarted, launched Manjaro, logged in. Background picture? Check. Panel (with menu, system tray, etc)? Check. Desktop? None. So I launched Caja, and Desktop immediately came back!

So it seems the proximate cause is, “Desktop is controlled by Caja, but Caja doesn’t launch on startup, so there is no Desktop on startup”.

So, how do I ensure that Caja does launch on startup? I think that is the ultimate cause of this problem.

Can’t exactly recall, but in your startup settings, or add/copy the caja.desktop file to your ~/.config/autostart/ folder and eventually edit it and add a delay to execute.

1 Like

Yep, that fixed it. I went into Menu / System / Preferences / Startup Applications, and it said nothing about starting Caja. So I ran “caja --help” to see what the options were, and the “–force-desktop” and “–no-default-window” options looked good, so I added a command to run “caja --force-desktop --no-default-window” at startup. Then on restarting computer, desktop now works.

I do wonder why I had to manually add that. And I wonder if that was the way the OS was doing that until about a week ago when my desktop got screwed-up.

But, it works, so I’ll take it. :slight_smile: Thanks for the help!

1 Like

The updates should not touch the user configs, but probably sometimes things get overlooked, or something else changed and the old config is not proper anymore and needs manual intervention/editing.
Glad you got back the functionality you wanted.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.