Master PDF Editor not showing any icons (Wayland, KDE)

Wondering if anyone else has the same issue, or can reproduce? Thanks

I’m running Manjaro, KDE, Wayland, Testing latest.

I have installed Master PDF Editor (and licensed it) three different ways: via AUR, via Discover (Flatpak from Flathub), and var .tar file from their website.

Each install I have the same problem, in Wayland, but not X11: I open the app, it shows the default Wayland icon instead of the application icon - in both the task manager and the window.

When I pin it to the task manager, it stays pinned and accessible, but with no app or Wayland icon, just a blank placeholder file icon.

I wrote to Master PDF Editor and they said they could not reproduce the issue.

I’ve not had this issue with other applications (I’ve had a different issue with some apps not showing window icons under Wayland).

Did you try changing in Settings-Appearance Application Style or Icon set. I don’t have any issue here with xfce Unstable version 5.7.08

Hi @jrichard326 , are you running Wayland? This is a Wayland-specific issue.

If you are, and the app works, please confirm the name of the .desktop file you have for the app?


I found the issue. I’ve now got it working correctly. The .desktop file name is wrongly named to work in Wayland.

In Wayland, the app_id of an application has to match the .desktop file name.

If it doesn’t, then the icons and pinning may not work properly.

For Master PDF Editor, the desktop file was wrongly named.

It should be “net.code-industry.masterpdfeditor5.desktop” instead of masterpdfeditor5.desktop

I will flag this in the AUR repository and to the makers, Code Industry.

I found the issue. It is a packaging issue.

In Wayland, the AppId must match the filename of the .desktop file
The app_id is org.onlyoffice.desktopeditors.desktop
In Appimage and Flatpak version this is correctly set
In the Manjaro respository this is set to onlyoffice.desktop
This should be changed in our respository version.
I changed the .desktop filename to org.onlyoffice.desktopeditors.desktop and it works.

If anyone is running Wayland and finds an app that does not either show it’s icons properly, or let you pin it to the task manager, try the following (using Master PDF Editor as an example):

  1. Find the .desktop file for the app and note the name, in this example masterpdfeditor.desktop
    It might be in /usr/share/applications or ~/.local/share/applications

  2. Open the .desktop file in a text editor and find out what the application executable file is called
    In this example it was: Exec=/opt/master-pdf-editor-5/masterpdfeditor5 %f
    So the executable was masterpdfeditor5

  3. Check the app_id

Enter this in a console: WAYLAND_DEBUG=1 your_program_exec_file_name |& grep ‘xdg_toplevel@[0-9]+.set_app_id’

In this example, I replaced your_program_exec with masterpdfeditor5

It should show you the app_id which might look something like

  1. Therefore the .desktop file should be named net.code-industry.masterpdfeditor5.desktop

If it’s not change it.

  1. Test the app now works correctly on Wayland.

  2. Inform the packager and/or the application developer and send them the link to this to explain.
    I’ve found a lot of apps do not conform to this standard and the developers/packagers do not seem aware of this simple fix to the issue.


1 Like

The developer (Code Industry) has received my further detailed report, and said that it would be fixed in the next release :smiley:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.