Mariadb server do not start

I have installed mariadb using pacman in terminal but it shows the following error as i run

sudo systemctl start mysqld

Unknown/unsupported storage engine: InnoDB

Did you followed the instructions in the Arch Wiki. At least one manual step is required before you can start the service.

Its not working because, innodb is not supported. I dont know what to do next

That is simply nonsense, innodb is supported out of the box:

Did you read the archi wiki entry @xabbu pointed to?
Namely did you initialize the database at the configured/default location via

$ sudo mariadb-install-db --user=mysql --basedir=/usr --datadir=/var/lib/mysql

And it is very important to delete everything that is now in /var/lib/mysql before you run the mariadb-install-db command.

If there is already stuff in /var/lib/mysql it will also result in errors.

Simply do what @freggel.doe said.

You don’t install MariaDB from pacman just like that you have to set up.

Well its nonsense only when it runs on all machines, it doesnot.

yes i tried that is not the error

Ok, i will do that

reinstalling after deleting the var/lib/mysql directory solved the issue

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.