Mariadb failed to start

Hello,

I am a new user to Manjaro moving from ubuntu. I am trying to install LAMP on Manjaro. I successfully installed Apache. But i get error that mariadb failed to start.

Job for mariadb.service failed because the control process exited with error code.
See “systemctl status mariadb.service” and “journalctl -xe” for details.

It is unfortunate and a shame that the old contents of Manjaro forums are gone, because last time i googled always top results will be from the Manjaro forums and they almost always solved the questions.

However the community has revived a new forum quickly and i hope newbies like me can get solutions just as easily. Thank you.

Just add archived to the beginning of any old forum link.

For example: https://archived.forum.manjaro.org/

Check out the Arch Wiki

https://wiki.archlinux.org/index.php/MariaDB#Installation

start with the required installations command and go from there. You need to do it exactly as written in the wiki article.

Since you already tried to start the daemon, make sure you start with a fresh /var/lib/mysql folder.


Thanks a lot for the tip. I found the guide that i followed previously.

Thank you for your reply. The linked post is the one that i was following earlier. I crucially missed the step where the mariaDB data directory is set.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.