Manjaro's ntp server US/Chicago daylight savings time error

today in the US/Chicago timezone we changed our clocks to -1 Hr (don’t ask me why I also hate it too)
However my Manjaro didn’t update the clock correctly.
I have fixed it but I don’t have enough privileges on these forums to posts the answer… I don’t know who to report that the manjaro ntp servers have the wrong configuration for the US central daylight saving time change.

I enabled ntp and when ran:
timedatectl show-timesync
it was using

FallbackNTPServers=0.manjaro.pool.ntp.org 1.manjaro.pool.ntp.org 2.manjaro.pool.ntp.org 3.manjaro.pool.ntp.org

so I changed /etc/systemd/timesyncd.conf and added:

NTP=0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org
FallbackNTP=0.pool.ntp.org 1.pool.ntp.org 2.pool.ntp.org 3.pool.ntp.org
RootDistanceMaxSec=5
PollIntervalMinSec=32
PollIntervalMaxSec=2048

then ran

systemctl restart systemd-timedated.service
systemctl restart systemd-timedated.service

and it worked…

I don’t know who to report the issue with Manaro’s NTP server configuration, but I posted here for now…

I’m kind of new to Manjaro (linux vet in other distros)

You might be a bit confused.

NTP servers do not care one bit about standard time/daylight savings time. They send time codes in UTC ONLY.

For example, radio station WWVB sets special bits in it’s time code to denote the time change, but the transmitted time is UTC.

On my machine this morning:

At 0100 EDT(UTC -4) UTC was 0500.

At 0159 EDT…UTC Was 0559

At 0200 EDT…clock reverted to 0100 EST [UTC -5). UTC was 0600 (no change).

Looks like both Arch Linux and Gnome have open bugs on Daylight Savings not being set correctly. In my case I am in the Toronto Canada EST time zone and can re-produce the issue you are seeing. This is the relating Gnome bugL

https://gitlab.gnome.org/GNOME/glib/-/issues/2219

Thank you… I tried reporting it elsewhere also without success…
Fortunately my problem is fixed, but I figure there are more

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.