Manjaro32 Architect, signature problems and conflicts installing gnome

manjaro32

#1

Hi everyone,
I recently got an old computer (HP Pavilion dv2000) that I just want to use as spare… However on my first pc I use manjaro gnome and I really love being able to have the same configuration on this other (shortcuts and so on, you know).

So I tried installing manjaro32 from the latest iso with architect but I was unable to complete because of a signature error.
I decided that for that pc also xfce could be great and so I tried with calamares and now I have a working manjaro installation with xfce. (post installation the signature is right, I don’t know why).

Today talking with a friend I discovered that he too had signature problems on a 32 bit installation, solved by the installation of archlinux32-keyring-transition and then again of archlinux32-keyring. I think this is not very cool!

But I hoped this could solve my problem and so it was, I followed the above steps on a VM and no more error occured. However, when I try to install gnome as DE, after the download Architect told me that dunst and dunstify are in conflict and exit with error.
This is quite annoying!

I think the signature problem is to solve on the new ISO!

Can anyone help me for the problem with dunst and dunstify?

I tried the steps here Manjaro Architect Install failing to install base packages but those two packages are not listed, I guess they’re installed as dependencies…

Thanks everyone


#2

Can you be more specific about the image you used?

Can you be more specific about the error?

This should be entirely unnecessary with the manjaro32 installer images.

I disagree. They solved their issue. :wink:

Yes. Those packages conflict.

Check a recent update #announcements thread. it should be in the Known Issues post.


#3
  • I used the last ISO (18.0.2-x32-stable-minimal-i686)
  • The error was Error 255… Pressing Ok I saw the terminal error, I don’t remember it exactly but it was with some key… this evening I’ll try again and post the output
  • Is unnecessary if you install with calamares but Architect needs it (I guess) because without follow these steps I was unable to install anything… I was surprised too
  • I read those announcements (I’m in testing on my first pc and there was an update recently which concerned them), but is there a way to install via Architect only one of these two? However this evening I’ll take it a look

#4

Ok the error without installing archlinu32-keyring-transition and then again archlinux32-keyring is this:

checking keyring... checking package integrity... error: linux-api-headers: signature from "Erich Eckner (just to sign arch packages) <arch@eckner.net>" is unknown trust :: File /mnt/var/cache/pacman/pkg/linux-api-headers-4.17.11-1.1-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)). Do you want to delete it? [Y/n] error: tzdata: signature from "Andreas Baumann (sign) <mail@andreasbaumann.cc>" is unknown trust

…2178 lines after…

:: File /mnt/var/cache/pacman/pkg/nilfs-utils-2.2.7-1.1-i686.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)). Do you want to delete it? [Y/n] error: failed to commit transaction (invalid or corrupted package (PGP signature))

Errors occurred, no packages were upgraded. ==> ERROR: Failed to install packages to new root


#5

@Chrysostomus Does Architect do anything interesting with package mirrors or repo selection?


#6

Here I finally solved so:
pacman -S archlinux32-keyring-transition
pacman -S archlinux32-keyring

Start Architect and then when I’ve to choose between minimal or full I open another terminal and
sudoedit /mnt/.desktop
sudoedit /mnt/.base
And remove gnome-shell-extension-manjaro-update from both (that depends on dunstify)
Then return to Architect and select minimal… Worked!

But I guess it hasn’t to be so difficult :sweat_smile:


#7

Well, it has option to change branch and choose mirrors. But in general it uses whatever the running system is using. I don’t remember putting in anything to change repos…

It optionally runs pacman-mirrors -iaB "${branch}", has option to edit pacman.conf and pacman-mirrors.conf.

That’s mostly it.


#8

The problem is that
gnome-shell-extension-manjaro-update and update-notifier haven’t yet been updated in 32bit repos when dunstify got decrepated. Which was quite unfortunate, because bundling dunstify with Dunst can be problematic if you want to use another notification daemon.


#9

Got it, thanks!
So with dunstify it’s a temporary problem for 32 version… It remains the key’s problem that comes out only with architect… I don’t know why

Thanks you all!