Manjaro XFCE freezes when attempting to install GRUB bootloader

Hi all, thanks in advance for your help.

I am installing Manjaro on a laptop for the first time (running it right now from a USB). But I am unable to get past the bootloader stage as the system will become completely frozen when I attempt to install the bootloader (mouse won’t move, keyboard unresponsive). Only way to recover is to hold the power button.

I am using an Acer Aspire ES 15. From what I can tell from Googling, other users of this laptop have had similar issues. I had at first tried to boot Linux Mint from a Live USB, but that would literally get stuck at the start up screen showing the Mint logo and never progress. Failing that, I started to try Manjaro (although I am preferring it to Linux Mint now anyway, so happy accident?).

When I run the Manjaro install GUI, the entire process runs fine until about 90%, when the loading bar displays “Installing bootloader”. Then the system freezes. When I return to Manjaro (booting through the Live USB), I find that the hard drive partitioning has succeeded and that storage is available to Manjaro, but other steps (like creating users and installing the bootloader) has not succeeded.

Just now I took steps to install GRUB from the command like using these commands

sudo manjaro-chroot -a

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=manjaro --recheck --verbose efibootmgr -v

However, that results in the system freezing just as it did when the installation GUI attempted to install the bootloader.

I have recreated the Live USB a couple times using different tools and get the same result.

I am willing to try installing Manjaro with KDE or GNOME instead of XFCE, however I’d like to stick with XFCE if possible as it performs quite well on this laptop.

Here is the output of inxi -Fazy

  Kernel: 5.8.11-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  driver=free nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  misobasedir=manjaro misolabel=MANJARO_XFCE_2011 quiet systemd.show_status=1 
  apparmor=1 security=apparmor 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Laptop System: Acer product: Aspire ES1-533 v: V1.04 serial: <filter> 
  Mobo: Acer model: Stego_AP v: V1.04 serial: <filter> UEFI: Insyde v: 1.04 
  date: 09/07/2016 
  ID-1: BAT1 charge: 26.9 Wh condition: 26.9/36.7 Wh (73%) volts: 12.6/11.3 
  model: COMPAL 0038314234314341 type: Li-ion serial: <filter> status: Full 
  Topology: Quad Core model: Intel Pentium N4200 bits: 64 type: MCP 
  arch: Goldmont family: 6 model-id: 5C (92) stepping: 9 microcode: 38 
  L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 8756 
  Speed: 796 MHz min/max: 800/2500 MHz Core speeds (MHz): 1: 796 2: 796 3: 796 
  4: 796 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass status: Not affected 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Integrated 
  vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
  chip ID: 8086:5a84 
  Device-2: Quanta VGA Webcam type: USB driver: uvcvideo bus ID: 1-7:4 
  chip ID: 0408:a010 serial: <filter> 
  Display: x11 server: X.Org 1.20.9 driver: intel unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") 
  diag: 389mm (15.3") 
  OpenGL: renderer: Mesa Intel HD Graphics 505 (APL 3) v: 4.6 Mesa 20.1.8 
  direct render: Yes 
  Device-1: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster 
  vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
  alternate: snd_soc_skl,snd_sof_pci bus ID: 00:0e.0 chip ID: 8086:5a98 
  Sound Server: ALSA v: k5.8.11-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Acer Incorporated ALI driver: r8169 v: kernel port: 1000 
  bus ID: 01:00.0 chip ID: 10ec:8168 
  IF: enp1s0 state: down mac: <filter> 
  Device-2: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi 
  v: kernel port: 1000 bus ID: 02:00.0 chip ID: 8086:24fb 
  IF: wlp2s0 state: up mac: <filter> 
  Local Storage: total: 938.73 GiB used: 168.6 MiB (0.0%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABD100 size: 931.51 GiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: 3J scheme: GPT 
  ID-2: /dev/sdb type: USB vendor: Verbatim model: STORE N GO size: 7.22 GiB 
  block size: physical: 512 B logical: 512 B serial: <filter> rev: PMAP 
  scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: N/A size: 5.70 GiB used: 168.6 MiB (2.9%) fs: overlay 
  source: ERR-102 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 48.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 191 Uptime: 6m Memory: 7.60 GiB used: 1.44 GiB (18.9%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1140 lib: 314 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: xfce4-terminal inxi: 3.1.05 

Furthermore, when attempting to install Manjaro using the CLI sudo setup, the bootloader also appears to fail to install.

I get an error message like this:

[Install GRUB][1] cp: cannot stat '/EFI/manjaro/grubx64.efi': No such file or directory

GRUB has been set as the default bootloader

Then, when I exit the installer it complains that there is no bootloader installed.

Have you disabled “secure boot” and “fast boot” in BIOS? That is the first thing I can think of that could help you. There might be more settings in BIOS that need tinkering before attempting installing Manjaro.

Regarding making a bootable USB, I really recommend ventoy, it has been super reliable in my experience.

Other than these two, I can’t really help.

Thanks @olividir

Secure boot is disabled, and as far as I know my system does not have fast boot in the BIOS.

I’ll try Ventoy as well. Thanks for your suggestions!

Additional info: I also attempted to install Manjaro KDE (latest). Same result. Systems freezes at 90% install, which is the bootloader step.

During the installation process I also erased the entire hard disk, which removed the Windows boot loader. The lack of a Windows boot loader didn’t improve things however.

Anyone else able to help with this?

if entire disk is erased, check if your bios support uefi. if yes then…

  1. create a 512mb first partition in fat32 [to be mounted as /boot/efi]
  2. swap / root / home etc to suit your needs

if not then you need to have an 8mb unformated partition prior to / [that means after the first 512mb fat32]

install grub to /dev/sda and i think you should be able to install

Are you manually partitioning? Can you show the output of these commands after an attempted installation?

sudo parted -l
lsblk -f
sudo efibootmgr -v