Manjaro XFCE 22.07 released By

I want to know how to keep the kernel version the same, and install things manually
with sudo pacman -Sy Application but it seems that is the only thing i can figure out without removing keyrings completing and not being part of the sudoers file and not locking the database completely, but either way a full upgrade with sudo pacman -Syu or sudo pacman -Syuu i reboot after installing through pacman and i get a black screen, that sometimes it turns on the monitor and sometimes it just flickers the left part of the screen with terminal white space.

Device: Opi-800 (Orange pi 800)

I managed to install firefox-116 but i click firefox and it will not open same with chromium, what am i doing wrong?

1 Like

I use ‘sudo pacman -Rdd’ to remove packages that are installed before its dependency and still will not improve boot with monitor functioning.

Flashing anything newer breaks my system i have even tried manajro-emmc-install from a sd card on usb card reader just to boot this file and flash newer image to the emmc, but keep endless cycle.

also newer xfce does the same thing as the old xfce so i am thinking i am approaching things wrong with using newer tactics instead.

You can stay on the same kernel branch as long as it is not end of life. On a rolling release system, you cannot install new packages without updating your system first because the new packages aren’t compatible with the older libraries on your system. You should never run pacman -Rdd unless you really know what you are doing. It sounds to me like you are running a partially updated system with missing dependencies. One of those two is the reason programs won’t launch for you.


Please use the image from manjaro official release.

Updating it will not cause black screen.

check this link


I really like the KDE Plasma 23.02 it is a rolling release i think i will just getting a bigger SD Card than 16 GBs maybe a Class 10 64 gb , should do the trick, its the only stable release so far on the SD Card but not stable on emmc, maybe because firmware needs to be “upgraded” i see so many things with TOW boot on the pinebook pro and Generic but don’t want to risk just installing anything for the Rockchip RK3399 not unless some one knows how to restore the orginal firmware on backup.

Thanks, i always use sudo pacman-mirrors --fasttrack 20 and it connects me to 20 countries and saved it to nano file, i always figure this corrects updates and installs for every package. ;D

Dont do that … it is asking for a partial-upgrade.
Use sudo pacman -Syu <package> to ensure you upgrade along with installing.

Dont make a habit of that either. Dependencies exist for a reason … skipping dependency checks should not be done lightly.
Usually I remove using -Rsn though, it wont automatically add dependencies, which I consider a good thing. (if removal is not allowed, check the tree, and add to removal, or rethink removal)

This simply sorts mirrors, nothing more.

… these are all just snippits in response to things mentioned here.

Your larger issue should be solved more radically (def: getting to the root) - start with a currently supported installation image.

1 Like