Manjaro XFCE 20.0.3 - Persistent USB - released

Thanks, Phil. I booted into Linux54 and tried again, but I get the same error. Tried a different USB, and also tried formatting to both Fat32 and Ext4, but it doesn’t seem to make a difference. I also tried reinstalling alma-git with its arch script dependency, but the error pops up again. I noticed that this started happening after GRUB and OS-Prober went through their recent “upgrades.”

then try with older versions of grub to see if that is the case.

Will see about downgrading GRUB when I get home from work.

@philm Issuing sudo downgrade grub I see multiple instances of version 2.04 (my current version) along with one 2.06. Would any of these work for testing purposes here?

for some reason i always get
“ERROR: device ‘UUID=foobar’ not found skipping fsck
mount: /new_root: cant find UUID=foobar,
You are now being dropped to emerygency shell
sh: cant access tty: job control turned off”

I even created a new img using your tutorials but it also gives this error.

i built with 5.11 and with latest grub and it built fine.

I buildt with kernel 5.10 and it did work. In the first run i got some errors. But when i did it again after a reboot and 10 Minutes it worked without error. Because i know that the USB-Stick is formated and therefor deleted this seems odd to me.

Later then i switched successfully to btrfs :wink:

  • I converted etx4 to btrfs with the stick at my desktop linux and the partition not mounted
    btrfs-convert /dev/*partition*
  • got the new UUID from
    lsblk -dno LABEL /dev/*partition*
  • mounted the Partition “1” and changed the grub.cfg with mc. Replacing every old UUID with the new one
  • mounted the partition “3” and changed the /etc/fstab. Commenting the first Line with “#” and adding a new line with UUID= … and 0 as last number instead of 1. I also added “,compress=zstd”

Thank you @philm

P.S.: I did forget to mention that i used a preset. manjaro-xfce
P.S.2: Now i deleted “ext2_saved”, and did compress everything i had installed with zstd:9 and the usage got down from 7.4G to 3.2G

Well it was a long time ago. Maybe I find time to spin a new one …

1 Like

I booted to the tty1, manually installed the xfce desktop, but am unable to log in to any user account. I created the account using useradd -m chris -p password
but now that I booted into the xfce login screen, I cannot login.
Help would be appreciated


I looked again at the user file and I think the problem was it wasn’t actually configured to save the passwords.
All working now

TIP for next time:
When you use a preset (like manjaro-xfce ) the USER will be created automatic. You only export the ALMA_USER for alma. Alma will ask you for the password when it is needed:

sudo su
export ALMA_USER=myUsername
alma create --presets ./presets/xfce-manjaro

But beforehand you have to download the presets to the directory you choose to start alma in.
P.S.: and the user is in sudoers :+1:

I did not name the usb-Drive when starting alma, but selected it inside alma from a list. Maybe this was the difference.

Oh! I click on the word direct below the paragraph that talks about a downloadable image and then it takes me to a page where I can download the ready-made USB-Image. I wish that had been more clearly explained.

Today the image is manjaro-xfce-20.0.3-20200704-USB8GB-unstable.img.gz. The forum will not permit me to put the link to this image. It is now saying 4hours to download the 1.6GB file.

I was also able to generate a working live USB with no GUI desktop on a Manjaro PC with the following:

sudo pamac install alma-git

ls /dev/disk/by-id/usb*

sudo alma create /dev/disk/by-id/usb-Generic_USB_Flash_Disk-0:0

Then create a newuser with root privileges and install a GUI desktop.

What do you mean? Links?

I wouldn"t bother, that is quite old and the updates alone will probably be the same size on top of that.

Yes, the link for the download image page is a sort of paperclip symbol. A link in a chain, I guess. The link takes me to a specific image file generated in 2020. Clicking on Description takes me to a community files page with several iso file images, some generated in 2021.

Yes. Updating that image did require over a hundred updates. Gparted was able to expand my partition on the USB to its full capacity.

So I just tried getting this working today, had a few issues and so I will document how I got around them. I am using the iso file [1] that was found in the original post (as of 20 may 2021), and I burned it via etcher.

No wifi connection

Use nmcli to connect to wifi, I followed a guide [2] which boiled down to running these commands in the shell:

nmcli device wifi rescan
nmcli device wifi list
nmcli device wifi connect SSID-Name --ask

No Sudo Access

As others have mentioned the default user manjaro doesn’t seem to have the ability to switch to the root user. I tried running sudo pacman -S nmapplet and it said that the user was not in the sudoers file.

To get around I used @Jazzlike-Joke 's information to login to the user account from the main xfce login screen (I was logged in as manjaro, and then I just pressed logout and then chose other from the drop down and typed in root as the user, no password was necessary).

After doing that I was able to do stuff as root, so the first thing I did was to change the root password by using passwd.

Then I tried to edit the sudoers file with visudo, it turns out that visudo couldn’t work because vi wasn’t installed, so I started off by just updating everything with pacman -Syu (this took a while for me, an hour or two, so be prepared), then ran pacman -S vi.

After vi was installed I edited the sudoers file with visudo and uncommented the line so that members of the group wheel could execute any command. (I knew that would work because I saw in user.toml that the manjaro user was added to that group).

Hopefully @philm can make it so that we don’t have to manually add this user as sudo, also if you can prepackage nmapplet into the os that would be great for new users who are not familiar with nmcli (I think normal manjaro xfce comes with nmapplet)

(Apparently I can’t post links on the fourm yet, so I have to put a space between the h so it doesn’t think it’s a link)

  1. h ttps://
  2. h ttps://

When I find time I might create a newer image out of this. Maybe we need to adjust things. Let’s see …

1 Like

Well, something weird just happened
While exiting alma chroot on an encrypted partition, there was an increase in disk activity. And next time I reboot I notice some files are gone: entirety of Documents and .vim ; also all gnome extension configs.
Nothing else was going on on my PC, so I think it’s the only culprit

EDIT: Ah, also /home/timeshift folder with backups is also gone

It has happened once more, now on “create”.
I was able to catch the error

2021-05-23T15:00:33.505Z INFO alma > Unmounting filesystems 2021-05-23T15:00:33.580Z WARN alma::storage::mount_stack > Unable to umount /tmp/.tmpm1XgCf: EBUSY: Device or resource busy Device alma_root is still in use. 2021-05-23T15:00:33.633Z WARN alma::storage::crypt > Error closing alma_root Error: Failed unmounting filesystem: /tmp/.tmpm1XgCf, EBUSY: Device or resource busy
Sadly without debug :frowning:
After this, same folders got deleted.
So when it can’t unmount encrypted partition, it wreaks havok on other ones

I beg your pardon but where to download your USB-image? (no link under the bold text)

It’s at the bottom of the post, with link text “direct”.