Manjaro won't wake up after sleep

So, The title says it all my manjaro gnome set-up doesn’t wake up if I put my laptop to sleep (Suspend), When I open up the lid back again I don’t see anything my display just doesn’t turn on at all, Only my keyboard led gets lit. Any idea why it could be happening? I’m running 10th gen intel chip with integrated graphics and modesetting driver.
P.S - I tried switching to Wayland as I thought it might be an x11 issue but still it doesn’t work.

``> Aug 31 11:20:02 hostname NetworkManager[696]: [1598853002.1040] manager: sleep: sleep requested (sleeping: no enabled: yes)

Aug 31 11:20:02 _hostname_ ModemManager[732]: <info>  [sleep-monitor] system is about to suspend
Aug 31 11:20:02 _hostname_ NetworkManager[696]: <info>  [1598853002.1042] device (enp1s0): state change: unavailable -> unmanaged (reason 'sleeping', sys-iface-state: 'managed')
Aug 31 11:20:02 _hostname_ gnome-shell[1400]: Ignoring excess values in shadow definition
Aug 31 11:20:02 _hostname_ gnome-shell[1400]: Ignoring excess values in shadow definition
Aug 31 11:20:02 _hostname_ gnome-shell[1400]: JS WARNING: [resource:///org/gnome/shell/ui/popupMenu.js 776]: reference to undefined property "_delegate"
Aug 31 11:20:02 _hostname_ kernel: r8169 0000:01:00.0 enp1s0: Link is Down
Aug 31 11:20:02 _hostname_ NetworkManager[696]: <info>  [1598853002.4531] device (wlp2s0): state change: disconnected -> unmanaged (reason 'sleeping', sys-iface-state: 'managed')
Aug 31 11:20:02 _hostname_ NetworkManager[696]: <info>  [1598853002.4635] device (p2p-dev-wlp2s0): state change: disconnected -> unmanaged (reason 'sleeping', sys-iface-state: 'managed')
Aug 31 11:20:02 _hostname_ NetworkManager[696]: <info>  [1598853002.4639] manager: NetworkManager state is now ASLEEP
Aug 31 11:20:02 _hostname_ wpa_supplicant[862]: nl80211: deinit ifname=p2p-dev-wlp2s0 disabled_11b_rates=0
Aug 31 11:20:02 _hostname_ wpa_supplicant[862]: nl80211: deinit ifname=wlp2s0 disabled_11b_rates=0
Aug 31 11:20:07 _hostname_ systemd-logind[702]: Delay lock is active (UID 120/gdm, PID 1033/gnome-shell) but inhibitor timeout is reached.
Aug 31 11:20:07 _hostname_ systemd[1]: Reached target Sleep.
Aug 31 11:20:07 _hostname_ systemd[1]: Starting Suspend...

``

Anything in your xsession logs ? I had a similar issue on cinnamon turned out it was my Bluetooth mouse casing issues which was wierd

I couldn’t find a xsession log file in my /etc/X11 could you please tell me it’s location?

This is not enough information.

When you say “sleep” is it suspend or hibernate?
Which desktop environment are you using? KDE, XFCE, etc.
What is the journal saying when you do the sleep and wake up? journalctl

I second this. Without enough information, its hard to give advice for the problem.

Hi ! It happens when I suspend it, and I’m using gnome

Updated the question please check it again!

Please put console output like this in code tags. Otherwise it is very hard to read.

The log is confusing. It start with timestamp Aug 30 22:36:52 and it ends with timestamp Aug 30 22:17:17. The journals that I know have the newest entries at the bottom. How did you create this log?

The log seems to show the start of the suspend. Do you have an logs from the wake up process?

What is your kernel comandline? cat /proc/cmdline

Sorry, I’m a newbie when it comes to linux, I’ve deleted the log from the question I’ll post it again when I get back to my system,
P.S - I did a journalctl -r and outputted it to a file, Is there any other way by which I could generate only error specific output using journalctl?

journalctl -b
gives the current log

journalctl -b -1
gives the log from one boot earlier.

Pretty much a newbie myself (but trying hard to learn). There’s an manjaro log helper app in the official repos, it will get any log you want for you and help you upload it. Its a big help for people not used to the cli

Hii, I’ve tried several times but it can’t seem to capture any logs after waking up the system, I did that by noting the time from when system was suspended to the time when I tried waking it up again, I’ve pasted the logs from my last boot in the question and I don’t see any data after waking up the pc.

Hey, Thanks! The manjaro log helper app is really useful! :slight_smile:

Hello, @mbod and @sawdoctor, I’ve solved the issue and it turns out to be that Kernel version 5.7 was the culprit, And for a note! just switching kernels won’t fix the issue, If someone else is having the same issue then the kernel version 5.7 must be removed in order to fix it.
For someone who doesn’t know how to do so, Here’s the steps -
1.) Go to manjaro settings.
2.) Navigate to kernels
and then remove and install whichever kernel version you want!

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.