Manjaro wont start after update, LUKS encrypted

Hi there, after update that was yesterday, my manjaro doesnt boot. I have luks encryption that was enabled in Calamares.
tried this: GRUB/Restore the GRUB Bootloader - Manjaro
used cryptsetup luksOpen /dev/sda2 lvm with this guide btw
manjaro-chroot -a didnt work, used manjaro-chroot /mnt /bin/bash

some useful info:

sudo fdisk -l /dev/sda                                                                                                                                                                           INT ✘ 
Disk /dev/sda: 476.94 GiB, 512110190592 bytes, 1000215216 sectors
Disk model: Micron_1100_MTFD
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: 966C5C61-B7AC-CF45-9C65-7DB6DEC2286C

Device         Start        End   Sectors   Size Type
/dev/sda1       4096     618495    614400   300M EFI System
/dev/sda2     618496  981751960 981133465 467.8G Linux filesystem
/dev/sda3  981751961 1000206899  18454939   8.8G Linux filesystem

first rerun update from chroot:
pacman-mirrors --fasttrack 5 && pacman -Syyu
if no errors try booting with a different kernel, if you have only one, install another from chroot

This opens the encrypted container
and makes it available under

You have to then mount it … to somewhere (/mnt is a good choice)
and then tell manjaro-chroot -a to chroot into this location

manjaro-chroot -a
will not do
… give it the directory you want to chroot into

“Manjaro won’t start”
isn’t a particularly helpful description of the issue you might have

manjaro-chroot -a didnt work, chroot’d manually

How did you do that - chrooting manually … ?
There could be some clues.

sorry, i didnt chroot manually, i used manjaro-chroot /mnt /bin/bash

brother, thank you, i ran sudo pacman -S linux519, then updated grub config, and it worked! I had linux518

… but:
did you mount the opened (decrypted) volume to that location?
to /mnt

This won’t happen magically by itself - you have to do that.

… was the mount successful
before you tried chroot into it?

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.