Manjaro won't identify my SSD

Hello , i’m new in the Linux (leaving windows ) world and from the star i couldn’t solve a few problems .
So for few days i’;m trying to install Manjaro on my SSD however the manjaro installation won’t identify my SSD it only detects HDD
Another issue is that if i go to my Bios ( F2) and chose the boot options it only displays P1 and P5 witch does not launch the Manjaro OS however if i go to F11 fast bot it shoes me a third option P0 witch has the manjaro os installed and now if i want to restart my PC i will have to go to the F11 in fast boot and chose P0 otherwise i can’t get into my Desktop environment
Secure boost , fast boot disabled
Sata selected on achi
When i was on windows i’ve managed to install it on the SSD

What SSD is this? Or simply what device

An educated guess would suggest a difference in boot environment UEFI vs BIOS, and not all built-in firmware allows cross booting (i.e. boot device selection also selects boot environment accordingly). I don’t know which one you install on which, only you know. But all in all, if you want all OSes to be present in the boot selection, use the same method for all of them.

1 Like

After seeing numerous topics on dual-boot Windows/Manjaro combination and Manjaro not being displayed in grub or not being visible, I think it could be due to Windows being installed using legacy boot on GPT.

When Manjaro is booted from USB on a EFI enabled system it will boot in EFI mode and install in EFI mode. Most firmware which provides both Legacy boot (CSM or Compatibility Mode) and EFI will try Legacy before EFI and therefore Manjaro is only bootable when selected from the firmware boot override.

If this is the case, then - in theory - it should be possible to change from EFI to Legacy, by manipulating the partition table.

Could you please copy the text from your terminal after you have run below command (paste it into a comment - then select the pasted text and click the </> button in the topic toolbar to format the text).

sda1 Linux        /
sdb1 Empty        
sdb3 Linux        
lsblk -o name,rota
sda       1
└─sda1    1
sdb       0
├─sdb1    0
└─sdb3    0
sr0       1

The mention of Windows - lead me to believe it was a dual-boot system.

The output indicates only Linux type partitions.

However sdb1 has no partition type and sdb2 is not listed - is there a unused gap between sdb1 and sdb3?

All in all it is awkward how the sdb is partitioned.

Also - in your system firmware - you mention Secure boot and Fastboot disabled.

How is the boot defined? Is it Legacy (CSM) or EFI - as I mentioned - this option decides whether Manjaro ISO boots as EFI or as Legacy.

Could you expand your device info with


And partition info on the disks

sudo fdisk -l /dev/sda

And the SSD

sudo fdisk -l /dev/sdb

As a legacy i think

This explains why your Manjaro only boots when using boot override.

You have one Legacy boot and one EFI boot - the legacy boot takes priority over EFI. Check my theory notes linked in my first comment.

If this is the case, then - [in theory]- it should be possible to change from EFI to Legacy, by manipulating the partition table

I don’t have and i didn’t want dual boot i need just 1 OS

sudo fdisk -l /dev/sda
[sudo] parolă pentru mihai: 
Disk /dev/sda: 931,51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: ST1000DM003-1SB1
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xbd046ae3

Device     Boot Start        End    Sectors   Size Id Type
/dev/sda1  *     2048 1953520064 1953518017 931,5G 83 Linux
sudo fdisk -l /dev/sdb
Disk /dev/sdb: 111,79 GiB, 120034123776 bytes, 234441648 sectors
Disk model: SSDPR-CL100-120-
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x2cd96550

Device     Boot   Start       End   Sectors  Size Id Type
/dev/sdb1  *          0   5869439   5869440  2,8G  0 Empty
/dev/sdb3       5869568 234441647 228572080  109G 83 Linux

Both your disk are using MBR - I suggest you reinstall grub - to the disk which is set as the primary disk in your system firmware - as root run - replace $DEVICE with either sda or sdb

# grub-install --target=i386-pc --recheck --boot-directory=/boot /dev/$DEVICE

grub-install: error: /usr/lib/grub/i386/ doesn’t exist. Please specify --target or --directory.

A typo - sorry - the target should have been --target=i386-pc

grub-install --target=i386-pc --recheck --boot-directory=/boot /dev/sda
Installing for i386-pc platform.
grub-install: error: cannot backup `/boot/grub/i386-pc/gcry_sha512.mod’: Permission denied.

I have deliberately not included sudo in the example - instead I wrote run as root - also known as - with sudo.

with sudo it worked

udo grub-install --target=i386-pc --recheck --boot-directory=/boot /dev/sda
[sudo] parolă pentru mihai: 
Installing for i386-pc platform.
Installation finished. No error reported.

Now what can i do ?

reboot :slight_smile: - but I got the impression that you wanted run the OS from SSD - isn’t that the sdb device?

If you are in fact dual-booting - you may need to activate os-proper in /etc/default/grub - then rebuild the grub configuration.

On ssd i want but if i put sdb i receive this error :

Installing for i386-pc platform.
grub-install: warning: Attempting to install GRUB to a disk with multiple partition labels.  This is not supported yet..
grub-install: error: embedding is not possible, but this is required for cross-disk install.

I think mentioned the odd partitioning on sdb - it is most likely why you have issues.

You should clear the disk and reinstall.

I won’t advise how to do a reinstall - simply because I do not feel safe doing so - I may tangle myself into something I cannot get of easily - so maybe you should disconnect the spinning disk before installing - then there will be no issues - you can always reconnect the spinning disk - just remember which disk is primary disk in the firmware.

Over and out. :wave: