Manjaro won't boot stuck at recovering journal

Hi guys. I am new to linux and I really need your help. I don’t know why, but system won’t boot and after grub menu show only

/dev/sdc2: recovering journal
/dev/sdc2: clean, 476519/3662848 files, 7840227/14650980 blocks

I’ve tried pressing ctrl+alt+f1-12 but it doesn’t work.
I’ve booted from live usb and recovered last weekly image but it changed nothing.
I have amd graphics card and I was on stable 510 kernel. I have not done anything special to my system. Idk what happened :frowning:
What should I do?

Update: I’ve tried booting on runlevel 3 with ‘quiet’ removed. Now I see some kind of file system check in process and some errors.

Welcome here, @dwb :wave:

In the output you can see several I/O errors, seems the disk you used to install Manjaro on has defective sectors. You could try fsck from a live ISO boot to fix it.

Hello, Wollie :smiley: Thank you for your reply!
I have checked my root partition wich is on SSD and it’s ok. But my home partition contains some errors…

fsck from util-linux 2.37
e2fsck 1.46.2 (28-Feb-2021)
/dev/sdb1 contains a file system with errors, check forced.
Pass 1: Checking inodes, blocks, and sizes
Inode 46403289 extent tree (at level 2) could be narrower.  Optimize<y>? yes
Inode 46418352 extent tree (at level 1) could be narrower.  Optimize<y>? yes
Error reading block 187695366 (Input/output error) while getting next inode from scan.  Ignore error<y>? yes
Force rewrite<y>? yes

Now I am waiting for rewrite to finish. I suppose my drive should be replaced. But I hope it will work for now :crossed_fingers: I’ll update this reply, as soon as I will get any result.

Unfortunately, after 15 hours of fsck doing its job (actually I don’t really know if it was working because it gives no indication, but I suppose it was) blackout has happened :frowning_face: So I’ve just wasted my time.
I think it may help to redo it, but I don’t have time at the moment ( I’ve read it could take more than 30 hours to complete for a 2TB drive) so I’ve started coping my data to another drive and will use this as secondary for unnecessary files.

Summary for inexperienced ppl like me, maybe you have a similar problem.

  • the problem was the old drive with I/O errors (I’ve just checked it with GsmartControl and it’s having some health issues). It was the drive with home partition, not root.
  • system was not able to boot cause of fsck running during boot, though it gave no indication
  • you can skip it with the boot option fsck.mode=skip, it works only for 1 boot and it doesn’t solve the problem. But it can help you to get in the system though maybe It worked only because it was the drive with home partition, not root (just press E in the grub menu and add it at the end of the line which starts with ‘linux’)
  • or you can use other methods to get access to drives such as live USB, other boot options ( or maybe there is some key combination to use, I don’t know)
  • fsck should help but it can take a long time to finish its job. Don’t use it on drives that are in use, use it while booting from life USB. Also, you will need to check disk health anyway. Maybe there is a better option, but I don’t know.

Thank you for your reply Wollie, again. You were right.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.