Manjaro won't boot after Windows Update

Hi, I am new and need your help.

I run a Windows/Manjaro dual boot on my Dell laptop. Everything was working fine until I updated my Windows to the latest version today. Since the update the old boot manager is not showing up when I start my machine. When I enter the boot manager via pressing F12 during booting I get the option to choose UEFI BOOT > Manjaro. However, if I select this option, I get this:

error: unknown filesystem.
Entering rescue mode...
grub rescue> _

The ls command produces this output:

(hd0) (hd0,gpt6) (hd0,gpt5) (hd0,gpt4) (hd0,gpt3) (hd0,gpt2) (hd0,gpt1)

I hope that I am not the only one facing this problem and someone has already found a solution. Thanks for your help in advance.

Hi :wave:

you need to repair grub, but in rescue mode you have to set the correct path You need to figure out which partition has the boot directory, like this:

ls (hd0,6)/boot

(i guess windows overwrite it, grub thinks that the windows partition is the linux partition and says the filesystem is unknown, because it is ntfs).
Then set the correct path and boot:

set root=(hd0,6)
set prefix=(hd0,6)/boot/grub
insmod normal
normal

After that, you need to reinstall grub: GRUB/Restore the GRUB Bootloader - Manjaro

3 Likes

Thank you very much for helping me. I did as you told me, however I get this:

grub rescue> set root=(hd0,gpt6)
grub rescue> set prefix=(hd0,gpt6)/boot/grub
grub rescue> insmod normal
error: no such partion.
grub rescue> normal
Unknown command 'normal'.
1 Like

You need to use the correct partition and path. Is that the root/boot partition?

1 Like
ls (hd0,gpt6)/boot

gives:

./ ../ efi/ grub/ memtest86+/ linux419-x86_64.kver intel-ucode.img linux54-x86_64.kver vmlinuz-4.19-x86_64 vmlinuz-5.4-x86_64 initramfs-4.19-x86_64.img initramfs-4.19-x86_64-fallback.img initramfs-5.4-x86_64.img initramfs-5.4-x86_64-fallback.img
1 Like

ok try it again with:

(hd0,6)

(without gpt)

1 Like

Otherwise you can boot a manjaro install disk, open a terminal, type manjaro-chroot -a and type 1. Then repair it like at the link mentioned above.

that gives:

grub rescue> set root=(hd0,6)
grub rescue> set prefix=(hd0,6)/boot/grub
grub rescue> insmod normal
error: file '/boot/grup/x86_64-efi/normal.mod' not found.
grub rescue> normal
Unknown command 'normal'.
1 Like

ok partition was recognized, but typo? grup -> grub ?

1 Like

Oh wow I am quit stupid. That was it. I think everything works fine now. Thank you so much I don’t know what to say, you saved me.
Which post should I mark as solution?

Does it work also after reboot? If not you need to reinstall grub… (link is above).

Please, mark the first answer as solution :wink:

1 Like

I reinstalled grub right after the first boot and I rebooted once after that. So I guess everything should be fine again.

1 Like

Glad it worked for you :wink: Have a nice weekend :slight_smile:

2 Likes

You too, thank you so much again.